Google Maps component not saving API key

Wappler Version : 3.9.2
Operating System : WIN 10
Server Model: NODE
Database Type:MariaDB
Hosting Type:: DO / Docker

Expected behavior

What do you think should happen?

on adding API key it should save

Actual behavior

What actually happens?

Key doesn’t save

How to reproduce

See video

Sorry George, think this was my error, layout page did not have the maps component on the layout page, will confirm when i have things working or now

Sorry to report that was not the issue. key is NOT saving

@George this getting fixed today?

Guess that’s a no. how can I manually add an API key to a maps component to get this working? Where do i put it?

I experience this same issue. Tried using a different project, no luck. The api-key just wont stay put, for some reason. I’m on 4.0.0-beta.10 W10 with a nodejs project. @George any suggestions on how to properly save the api key for the Google Maps component?

I also get this error:

Thanks :grin:

To add to this, if I add the key manually in the script tag in layout page in NodeJS project, when I add some new component say places etc in a content page, it will clear out the key from the layout page script tag.

Hope this gets fixed soon.

Thinking this was overlooked initially, basically renders all map related features disabled

1 Like

This bug report is now 4 months old and renders all map functions useless. Can we have a fix please, surely it’s not that difficult?

1 Like

@Hyperbytes in the meantime you can add the api key directly in the code, appending it to this script in the head tags:

<script src=""></script>

Yes unfortunately it is not that easy to fix indeed and there is an easy bypass.

If adding the script line manually, will that get removed on save?

I have seen that happen only when adding Google stuff to newer pages.
Once its added, after that saving those pages does not cause removal anymore from main page.

1 Like

Just hit this as well, but with the added component of Directions on top of maps.

I found the easiest fix was to generate the scripts needed and then place within a partial so they don’t get messed with.