Frameworks not being added?

Ok, dumb question number 2 …

Just starting a new site after experimenting with routing. I have my frameworks set as below:


(Why Bootstrap 4 is included and can’t be removed is another issue)

But when I create a new page I get:

Are the frameworks not suppose to be added automatically?

I believe bootstrap is required for jquery and font awesome.

As far as why it is not added, try restarting wappler and see if that fixes it.

Restarting Wappler didn’t help.

As for the other issue, I meant why is FontAwesome 4 required - not bootstrap. I added FontAwesome 5 but it still added FontAwesome 4. Not a big deal. I’d rather have the auto adding frameworks working.

Have you tried saving your page Brad?

Yes, after saving the page I get:

Dumb question, but have you tried fully restarting Wappler and trying this again?

Yes, I have twice. Did some more testing … it works fine for .html files but doesn’t add them to .php files.

Should I mark this as a bug since it works with .html files but not .php files?

how exactly did you create your new file? From the File Manager?
Try the [ + ] on the tabs.

1 Like

Yes, it seems to work as it should from the tabs, just not from the File Manager.

Thanks! I will use the tabs.

Maybe the same as:

what type of file are you creating from the File Manager? and after creating you just double click to open it?

Yes, creating a PHP file and double click to open. Except the proper folders are all being in generated.

Now that I am trying to restrict some pages, I am using ASP.NET and I am experiencing the same thing. However I create the new ASP.NET page, it does not add the frameworks to the page. This also is the case with classic asp. Yes, I’ve restarted Wappler, tried using the “Add File” icon, right click on root and click “Create File”, it’s all the same, no frameworks.