File Upload Throwing a 404 Error

Aloha Wapplers, We are following the Docs here: and Brian’s most excellent video here: After multiple attempts we are getting a 404 Not Found Error when we attempt to upload a file.

Permissions on the destination file on the server is 0755. We feel it may be something stupid on our part but after many attempts we are still getting the same results. Your expert Wappler guidance would be greatly appreciated. Thank You in advance for your assistance. All the Best. LLW

Please click on the preview/response tab to see the exact error message …

Thank You for your prompt response Teodor :grinning: 404 Not Found, Here is a screen shot

It looks to me your server action is not uploaded to the server.
Please make sure that the whole dmxConnect folder and its content is uploaded.

dmxConnect appears to be there, I’m Working on a screen shot now.

What about the files inside it, and the files inside the dmxConnect/api folder?
Please select it and click the upload button in the file manager

dmxConnect Local and Target Side by Side Comparison

Please provide screenshots of what have you set up for the upload step in your server action.
And also please make sure to enable the detailed error reporting on your server.

Your upload form points to dmxConnect/api/files/upload_files.php
I see no such a server action on your screenshots.

Please see my last reply. You have pointed to a non-existing server action.

Man are you fast, I’m checking now.

Thanks for your patience and very quick response. Here is a screen shot of what I (a newbe) believe is the Server Action>files>uploader in the Wappler GUI and the dmxConnect>api>files.uploader.php in the Target server. Please let me know what I am missing?

Thank You in advance.

Your form on the page points to: dmxConnect/api/files/upload_files.php
Select your form in the app connect panel and select the right server action. The one that it points to currently does not exist.

Well that was embarrassing, Thank You! The uploaded file is Successfully :clap: on the server however it threw a 500 Internal Server Error. :confused:

Seems you have some permission issues, most probably on the temp folder. Please check this.

Thanks for rolling with me Teador, I feel we are close.

I updated the Dynamic Events Success and the 500 Error went away. We are getting the Green Wappler Notification Success Message and the Status Code 200 unfortunately the file is “Not” uploading to the server now :confused:
The tmp directory has permissions set to 0755
Here are the screen shots:


Hi Teador,

Trust this note finds you well and Thank You for working with me on this File Upload issue. Just FYI, I changed the tmp folder permissions to 0777 and tested again with the same results. Here is the “Failed to open stream: Permission denied” error.

  1. {code: 0, file: “/home/wapzed/public_html/dmxConnectLib/lib/core/FileSystem.php”, line: 178,…}

  2. code: 0

  3. file: “/home/wapzed/public_html/dmxConnectLib/lib/core/FileSystem.php”

  4. line: 178

  5. message: “move_uploaded_file(/home/wapzed/public_html/uploads/{name_n}.jpg): failed to open stream: Permission denied”

  6. trace: “#0 [internal function]: exception_error_handler(2, ‘move_uploaded_f…’, ‘/home/wapzed/pu…’, 178, Array)↵#1 /home/wapzed/public_html/dmxConnectLib/lib/core/FileSystem.php(178): move_uploaded_file(’/tmp/phpp9UrFF’, ‘/home/wapzed/pu…’)↵#2 /home/wapzed/public_html/dmxConnectLib/modules/upload.php(196): lib\core\FileSystem::move_uploaded_file(’/tmp/phpp9UrFF’, ‘/home/wapzed/pu…’)↵#3 /home/wapzed/public_html/dmxConnectLib/modules/upload.php(150): modules\upload->parse(Array, Object(stdClass))↵#4 /home/wapzed/public_html/dmxConnectLib/lib/App.php(173): modules\upload->upload(Object(stdClass), ‘upload1’)↵#5 /home/wapzed/public_html/dmxConnectLib/lib/App.php(107): lib\App->execSteps(Object(stdClass))↵#6 /home/wapzed/public_html/dmxConnectLib/lib/App.php(72): lib\App->exec(Object(stdClass))↵#7 /home/wapzed/public_html/dmxConnect/api/files/uploader.php(91): lib\App->define(’{\n “settings”:…’)↵#8 {main}”

I’m inclined to start over again fresh and would appreciated your confirmation that 0777 on the tmp folder should work . . . Or should I be looking at another folder?

I Look forward to hearing from you when you can and of Course Thank You in advance!



Yes your temp folder needs to have all the permissions

Could it be because yout tmp folder is outside of your root folder (public_html)?