Etimeout when connecting to Digital Ocean

Yes in this circumstance that is correct.

Have you downloaded the SSL certificate and directed the CA Cert path to it? And the certificate is located within your Project? In your image it is blank and should be pointing towards the certificate.

You can download the certificate from D.O within the Connection Details panel.

Ok so if I’m following:

  1. I need to make a droplet.
  2. I need to download my CA certificate and upload it where it says CA cert
  3. should be good to go??
  1. Not essential if you are just connecting to the database but when you come to connecting your droplet it will be necessary to add it as a trusted source, or if not a droplet then the I.P address of the host you will be using.

  2. REQUIRED! You will not be able to connect without the SSL certificate.

  3. Dial in 2 and you’re 3.


Cheese, it won’t let me put the certificate in CA cert. I downloaded it from DO

Insure the certificate is within the root directory of your Project. Then select it.

I’m sorry… I don’t know what that means

The directory where you have created your Project (where its files are located), within that directory is where you need to place the certificate file you downloaded. It must be within the Projects directory.

No need to apologise Parker. We all go through the learning process.

same problem…

Make sure the username you are using is using the correct password. Double check it. We have used D.O databases for multiple Projects and have rarely had an issue outside of user error. Worth checking all the details again. Then be sure to click Test.

I’m sure it’s still a problem with the certificate. I have the giant file from when I downloaded Wappler, but in that file I don’t see any project folder or anything like that

Take a look at the documentation with regards to Projects. It is a little outdated (GUI wise) but the principle is still pretty much the same. Should give you a better idea and help to get a grasp on the basics.

I’m doing that all correct. I’m putting the certificate in the right place then. I don’t get why I’m getting this error. Is it possibly something I’ve done wrong on DO. Maybe my database isn’t hooked up there or something like that. Is there a way I can check all that?

If the Project is Docker try placing the certificate in the:


Directory. Then update the connection to point at it.

still doesn’t work. I’ve tried using a custom profile, I’ve tried Digital Ocean RDS, I’ve tried SQL 8 instead of Maria/SQL I’ve tried so much at this point. Is there a help line where I can explain this to someone. I know you’ve been very helpful, but I might need more help.

Well it seems like you have some settings or access wrong. Maybe try to turn off Use SSL

Other way is to use the new Resource Manager to create or import your existing digital ocean database clusters and select database connections from it onwards, see:

1 Like

Thank you for all the help! I’ve overcome this annoying roadblock thanks to this community.

1 Like