Error in DB Session - No Schema Has Been Selected

Wappler Version : 4.9.1
Operating System : W10
Server Model: NodeJS
Database Type: PostgreSQL

There is no option anywhere in Wappler UI to set the default schema to be used with a Postrges DB connection.
When using the DB in Session settings in Server Action, its throwing an error: No Schema Has Been Selected

Workaround:
Setting the schema manually in the DB JSON file.
image

Don’t you have public schema in your Postgres db? That is usually the default.

Nope. Deleted that I think.
And even if it would exist, I don’t think the username & pass would have worked. So it would have thrown a different error.
In any case, it should be dynamic, even if set to public by default in the UI.

Well it is all about database setup. If you have deleted the default schema, you should appoint another one in the so called search path in Postgres.

See:

That seems helpful when there is only one schema. Will try it out asap.

An option would still be needed in Wappler UI for multi-schema DB.

@George Checked the default search_path as suggested in the shared link.
Its set to app,public. So app is the default one.
I used the same credentials as used in Wappler to check this.

@George / @patrick Bump.
This is getting really annoying now. Can’t keep discarding changes in db.json file everytime I open Wappler or switch projects. Is this going to be fixed?

Did you make changes in the db.json to get it to work and Wappler is overwriting your changes, is this correct?

Yes.
Turns out, I had not changed the code in TARGET specific db.json file.
After doing that, this issue of having to keep discarding changes was gone.

The original issue of not having an option to select schema in the UI is still pending.