Email-will not be send

serverconnect
#1

I have a .php site and followed all instructions below. My problem is as follows. Giving up no email goed ok (required message), giving up an unknown message will be checked against the database and I get the error message I gave up. The page is even redirected when I only give up below smtp.gmail.com on port 587. If I take it away it will not be redirected. BUT also when i give up my personal emailaddress and password nothing will be send, only a redirection takes place,

Email Setup on localhost
#2

Hello Peter,
Are you sure you’ve properly setup your email settings?
Google require you to enable some settings so that the smtp can be used like this… https://support.google.com/accounts/answer/6010255?hl=en

#3

implies I need G-suite, never read that that is necessary. I tried my organizations smtp as well (use login to outlook) and no luck there either. what bothers me is that I am redirected UNLESS i give up a bullshit smtp like smtp.nothing.com. Soonest I give a valid smtp without a valid username I will be redirected…

#4

You don’t need G-suite …
It’s already explained how to enable your gmail smtp to be used:

  1. Go to your Google Account.
  2. On the left navigation panel, click Security .
  3. On the bottom of the page, in the Less secure app access panel, click Turn on access .

Also - the redirect is not working because you probably have not set up the smtp settings properly, which causes the server action to run with an error.
You can debug and see what’s the error as explained here: Debugging Problems

#5

Hi Teodor,

The less secure app function is not visible with normal gmail accounts. Niet means not and the red arrow hide smy emailadress Niet me je huidige means not with your current account…
To convince you have a look at the second image.

#6

It is available and i am using it with my personal Gmail account:

I don’t know what could be the issue with your gmail account, but in order to use google smtp google require you to enable this. It is not our requirement.

Maybe just use some smtp server which you know works fine.

#7

Hi Tudor,

That is only true if you put out two-way authentication. I figured out you can have that on and apply for an app password (16 signs) (which I did). I used that one, no luck. Anyway I put 2-way out now and still the same thing. I checke dthe gmail account and password no worries on that one. The input form is called email, but the post as well (name…)

image

image

email itself:

You requested a password, reset, you can do so here

#8

to be precise put out 2-way and put on less secure option again…

#9

I don’t really understand your last posts.

Is it now working or not?

#10

no it is not with the options you suggested. I am still redirected (so kind of success as without any valid smtp like smtp.stupid.com I am not redirected.) My problem is I get no email. nothing

#11

#12

Peter, it’s hard to understand you.
Are you redirected when you are using valid smtp data or when you are not using valid smtp data?
Is the email received with valid smtp data?

#13

I am redirected with a valid smtp ONLY (even without a username and password), BUT NO EMAIL IS BEING SEND and that is the problem…

#14

Try using port 465 and SSL enabled with the google smtp.

#15

No l u c k. Sometimes …

#16

with the 587 variant is gets REDIRECTED (No mail), with the 465 (and ssl) No redirection and no email.

#17

Peter, please set it to 465 and SSL, enable the output option in the send mail step, and then debug the error message as per instructions i sent earlier:

It’s not a matter of luck … it’s all about the configuration. If you configure it wrongly it won’t work.

#18

Teodor,

I am aware it is no luck, but i thought wappler was the easy to use (no coding?) product and I thought I had to do no further email xammp set-up. I still think i do not.

  1. {code: 0, file: “C:\xampp\htdocs\FCRTFSNB\dmxConnectLib\lib\mail\Smtp.php”, line: 100,…}

  2. code: 0

  3. file: “C:\xampp\htdocs\FCRTFSNB\dmxConnectLib\lib\mail\Smtp.php”

  4. line: 100

  5. message: “fsockopen(): unable to connect to ssl://smtp.gmail.com:465 (Unable to find the socket transport "ssl" - did you forget to enable it when you configured PHP?)”

  6. trace: “#0 [internal function]: exception_error_handler(2, ‘fsockopen(): un…’, ‘C:\xampp\htdocs…’, 100, Array)↵#1 C:\xampp\htdocs\FCRTFSNB\dmxConnectLib\lib\mail\Smtp.php(100): fsockopen(‘ssl://smtp.gmai…’, 465, 154762360, ‘Unable to find …’, 5)↵#2 C:\xampp\htdocs\FCRTFSNB\dmxConnectLib\lib\mail\HtmlMimeMail.php(718): lib\mail\Smtp->connect()↵#3 C:\xampp\htdocs\FCRTFSNB\dmxConnectLib\lib\mail\Mailer.php(114): lib\mail\HtmlMimeMail->send(Array, ‘smtp’)↵#4 C:\xampp\htdocs\FCRTFSNB\dmxConnectLib\modules\mail.php(64): lib\mail\Mailer->send(Object(stdClass))↵#5 C:\xampp\htdocs\FCRTFSNB\dmxConnectLib\lib\App.php(159): modules\mail->send(Object(stdClass), ‘’)↵#6 C:\xampp\htdocs\FCRTFSNB\dmxConnectLib\lib\App.php(128): lib\App->execSteps(Object(stdClass))↵#7 C:\xampp\htdocs\FCRTFSNB\dmxConnectLib\lib\App.php(98): lib\App->execSteps(Array)↵#8 C:\xampp\htdocs\FCRTFSNB\dmxConnectLib\lib\App.php(71): lib\App->exec(Object(stdClass))↵#9 C:\xampp\htdocs\FCRTFSNB\dmxConnect\api\Passwords\requests_new.php(8): lib\App->define(Object(stdClass))↵#10 {main}”

Name

#19

I appreciate all your comments, but please do not think I think it easy. this costs me the day, so yeah how easy is that?

#20

and fyi with the 587 without ssl I get no error at all, and I get redirected. Again only the email is not being send…