Docker deploy error: UnixHTTPConnectionPool Read timed out

Hi guys, I thought that fixed the issue but I still can’t deploy. I’ve tried both Alpine and Debian 11 - Bullseye. This is the new error I now get:

ERROR: for magicmeta__development_db_1 UnixHTTPConnectionPool(host=‘localhost’, port=None): Read timed out. (read timeout=60)

ERROR: for db  UnixHTTPConnectionPool(host='localhost', port=None): Read timed out. (read timeout=60)
ERROR: An HTTP request took too long to complete. Retry with --verbose to obtain debug information.
If you encounter this issue regularly because of slow network conditions, consider setting COMPOSE_HTTP_TIMEOUT to a higher value (current value: 60).
Error Launching Services!

Any pointers appreciated.

Try re-starting Docker or as suggested in the output increase the COMPOSE_HTTP_TIMEOUT to 120…

Try the following:

export COMPOSE_HTTP_TIMEOUT=120 (as mentioned in the output)

See if any of the above help? First simply try the Docker re-start…

Thanks for the reply Dave.

I’ve tried restarting Docker a few times, as well as Wappler no luck.

Can you let me know where I would input those commands to increase the timeout, please?

Here you go @mgaussie

You should be able to set them within the SSH terminal from within Wappler.

I don’t seem to have a SSH Terminal in this project - perhaps because it’s not been able to build the docker part yet. Thank you for the above link, i’ll try and figure it out from that - appreciate it.

I have just experienced the same issue, and I’m using an Intel Mac!

Here, this is what solved the problem:

Open the project in VSCode and go to the docker-compose.yml file inside .wappler:

        max-file: '5' # 5 -> '5'
        max-size: '10m' # 10m -> '10m' (optional)

Wappler team might want to consider update their docker-compose.yml to tackle this weird bug

thank you for this - this solved the issue! Noting there are two sections within the file one for db and one for server.

Thank you @Apple!!!

Good catch - will be solved in todays update

This has been fixed in Wappler 4.4.3

This topic was automatically closed after 47 hours. New replies are no longer allowed.