DO server using resource manager can't connect

I’m still having terrible luck with the resource manager and setting up servers.

I have successfully setup a staging server, and a managed db.

Now trying to do the same thing and create (or import) a production server.

I have done this half a dozen times, either creating the server in Wappler, or creating in the DO panel (where I can see the “pauka” ssh key is attached to the droplet, but I always end up without being able to connect.

I can perform the system check just fine:


But refreshing, or restarting Wappler, or restarting the computer, all leave me unable to connect, while the staging server works fine.

I’ve compared the fingerprint of the ssh key, to that on the Security panel of DO, and they match.

I’m at a loss. :man_shrugging:

@George any ideas here?

I can SSH through Wappler to both droplets.

But for 1 droplet, it errors when attempting to get the project info, and also fails when attempting to attach the cloud provider to a target:

Error: All configured authentication methods failed at doNextAuth (/Applications/Wappler.app/Contents/Resources/app/node_modules/ssh2/lib/client.js:803:21) at tryNextAuth (/Applications/Wappler.app/Contents/Resources/app/node_modules/ssh2/lib/client.js:993:7) at tryNextAgentKey (/Applications/Wappler.app/Contents/Resources/app/node_modules/ssh2/lib/client.js:1002:11) at USERAUTH_FAILURE (/Applications/Wappler.app/Contents/Resources/app/node_modules/ssh2/lib/client.js:366:20) at 51 (/Applications/Wappler.app/Contents/Resources/app/node_modules/ssh2/lib/protocol/handlers.misc.js:337:16) at Protocol.onPayload (/Applications/Wappler.app/Contents/Resources/app/node_modules/ssh2/lib/protocol/Protocol.js:2025:10) at AESGCMDecipherNative.decrypt (/Applications/Wappler.app/Contents/Resources/app/node_modules/ssh2/lib/protocol/crypto.js:987:26) at Protocol.parsePacket [as _parse] (/Applications/Wappler.app/Contents/Resources/app/node_modules/ssh2/lib/protocol/Protocol.js:1994:25) at Protocol.parse (/Applications/Wappler.app/Contents/Resources/app/node_modules/ssh2/lib/protocol/Protocol.js:293:16) at Socket.<anonymous> (/Applications/Wappler.app/Contents/Resources/app/node_modules/ssh2/lib/client.js:713:21) at Socket.emit (node:events:390:28) at addChunk (node:internal/streams/readable:315:12) at readableAddChunk (node:internal/streams/readable:289:9) at Socket.Readable.push (node:internal/streams/readable:228:10) at TCP.onStreamRead (node:internal/stream_base_commons:199:23)

Are your SSH keys added to the SSH Agent in Wappler Resource Manager?

Also do you SSH from Wappler Resource manager? From the server properties?

You mean like this?

Yes.

Ah it might be Ubuntu 22 and old rsa ssh key you are using.

For new servers we automatically enable the old rsa keys compatibility but for older servers you might have to do it manually. See:

1 Like

Okay I’ll try that. But why would the staging server work fine and the production not work? They are both Ubuntu 22. But I’m noticing the staging server that works has more IPv4 entries than production, but maybe that is because it has a deployment already??

Well check the ssh_config on the server to see if the setting is in there as outlined in the article above

1 Like

That did in @George. Thanks for the article link. Made the suggested change (to both servers so they match) and both are now working.

1 Like