Directories being locked when Wappler Open

Thanks for reporting an issue! Spend 60 seconds reading this…

  1. Before reporting, make sure you have the latest version of Wappler.
  2. Make sure you have searched the forum first for similar issues being reported
  3. If it is a general web related issue - do a Google Search first
  4. Issue tracker is only for bugs and feature requests, in English only.
  5. Learn how to report bugs effectively

======== TEMPLATE BUG FORM ========

Wappler Version : 2.2.1 (appled to 2.2.0 also)
Operating System : Windows 10

Expected behavior

What do you think should happen?

Files should not be locked

Actual behaviour

What actually happens?

Directories and files are locked

How to reproduce

  • Detail a step by step guide to reproduce the issue
  • A screenshot or short video indicating the problem
  • A copy of your code would help. Include: JS, HTML.
  • Test your steps on a clean page to see if you still have an issue

Very early report of this with little supporting info but thought i would document this as I lost a lot of time yesterday due to it

I have recently been busy with a site and found that some directories (and i think in 1 case a file) , once created became locked and could not be deleted or renamed locally throwing this message in Windows


I tried various solutions offered by Google to no avail and finally downloaded Microsoft Process Explorer which showed that Wappler had placed locks on several files and folders.

This was confusing as I had tried closing Wappler in case of that possibility and even a reboot did not seem to resolve it

I finally identified that these locks are present even when just the tray icon process was active (which of course opens automatically on restart)

Closing the tray icon appears to release those locks allowing delete/ rename

So if anyone also hits this issue,. the solution is easy, close Wappler COMPLETELY including tray icons to rename/delete locked files

1 Like

I took 65 seconds to read it. I need to read faster ! :innocent::stuck_out_tongue_winking_eye:

Hi Brian,

This is very strange, we don’t have any problems deleting files and folder of Wappler projects, when Wappler is running.

Which folders exactly are you trying to delete? Some sub folder in a Wappler Project - or the whole project root folder? Or some folders in Wappler configuration?

I will try and recall exactly what i did when i first observed this

I noticed it when duplicating a WHMCS template from within Wappler from the file manager. (right click and select duplicate)
If I recall this didnt appear to work so i then dropped into file explorer and did the copy there creating a folder named “six - copy”. Not begin the most friendly of file names i tried rename and got the error
As this seemed at that point to relate to the windows file manager copy process I never considered it to be Wappler related

I later decided to restructure the site and tried a copy of basically the entire site into a sub directory only to fine a few other directories could not be moved (same error message)
Several ways offered by google to resolve this all failed so i loaded a copy of MS Process Explorer which showed active Wappler processes related to that directory (and others i didn’t even realise were locked)

So i then closed the tray icon and everything could be deleted / renamed as expected

I am very sorry this is so vague but i never thought this may be Wappler related

So the answer to your question is:

A folder created manually with windows explorer
Other folders automatically created by WHMCS install

I would have attributed it to external factors like WHMCS had the locks not been released on closing wappler.

I appreciate you may not be able to do anything based on this limited information or indeed it may be a chance one off error but I did want to warn the community just in case anyone else experienced this issue to save them wasting time investigating as I did and to offer the solution

Hi @George @Hyperbytes,

I had the same issue. I cold not delete the .git folder while Wappler was running in the tray.

Have not checked it in a few weeks.


What you see in the Process Explorer is that Wappler has handles to those project folders. But those are just watches - as we watch for changes. They don’t lock files or prevent file deletes