Digital ocean droplet is getting full, how to sftp?

Something is filling up my docker droplet.
It’s not old docker containers (docker system prune only frees up 500mb now instead of 3GB before).

To figure out what is happening I’d like to SFTP into the server. But I need a root password.
I think Wappler made that?
Because I only see a reset button in the DO settings

Where can I find it?

Wouldn’t you want to connect using the public key method?

Maybe I do? Do you have a bit more info :smiley:

Actually, have you tried using Wappler file manager?

Set your active target and then:

This is an issue. The UI clean option removes less and less over time and becomes slower and slower. I manually login to the DigitalOcean console and jump on each individual droplet and manually delete them occasionally from the command line. It speeds the Wappler process up also.

Yeah I’ve gone through there and at least cleaned up upload folders, other than that I don’t see anything that can fill up my disk… I just removed about 30 pdf files, so not huge savings.

@scalaris you go onto the console and what do you do exactly? docker system prune ?
Because I’ve already been doing that command manually (the UI button never seemed to actually free up space). But as said, something is still filling up my droplet. And I’m int he dark. I’m not sure what’s happening

Use the command ‘ncdu /‘ to see the disk usage by folder. You may need to install it first by doing apt-get update and apt-get install ncdu

In your target settings have you set the Logging Max Files and Max File Size options? If so, what are they set to?

There should be one set each for Web and Database

The DB is split up from the droplet (digital ocean managed database).
I see it’s set to 5 and 10m image
Assuming m = MB, that shouldn’t be an issue?

Well, this is exactly what I wanted to do after getting FTP access.
Thank you!!

Sadly Wappler’s terminal is still visually buggy… but at least I managed to go to figure out it’s Traefik logs!

Now to go back to this thread… on top of the original question.
How can I SSH into my droplet without wappler’s built-in terminal (since it’s very visually buggy)? image

EDIT: nevermind, I found the answer to that in my own docs.
Sharing for whoever needs it.

  1. Install openssh VS code extension
  2. GEt ip address of droplet from dashboard
  3. Copy private and public keys from .docker/machine/machines/projectname
  4. Use vscode command (press F1) to open connection

Original question of the thread still stands. Where cna I get the root password to SFTP into the Wappler made digital ocean droplet?

Seems OK - was worth a quick check

1 Like

Well that is a great finding @karh! We have indeed limited the logging for the regular docker services, with options, but indeed not for the older Traefik global service. The new Services in the Resource Manager, do have logging options.

Anyway I will see if we can add logging options also for the older docker machine based Traefik installations.

Before you waste your time: I’ve set up my own traefik instance where I had turned on DEBUG level of logging.

So I don’t think others will have this same issue :slight_smile:

1 Like

No problem we will be adding the generic docker logging options, so if logging is on it will be at least controlled and auto rotated (cleaned up)

1 Like

Fixed in Wappler 5.4.2

This topic was automatically closed after 32 hours. New replies are no longer allowed.