Design panel not creating CSS rules


#1

I tried the new design panel today for the first time. I set up a css file in the project settings and, looking at the design panel, it seemed to be working as expected. However the changes were not being applied to the selected elements. The changes appeared in the design panel and the styles were added to the elements - but no css was written to the .css file.

I noticed this in the debug file:
[75428:80864:0313/135638.047:INFO:CONSOLE(8)] "Missing file", source: chrome-extension://fjjllfpmlaejicjkpknbdicdakiijgjp/Shared/DMXzone/dmxAppCreator/UI/styleEditor.js (8)*

I thought perhaps there was an installation problem, although I could see the file existed in the Wappler folder. However I opened another project and tried out the design panel - it worked without any problems.

I’ve tried restarting Wappler a couple of times, but this didn’t help. I wonder if there could be a problem with the project (this is the project I had the issue with - explained here.) If so, is there a way to resolve this - eg a cache which can be deleted etc.?

  • I should have probably included this too:
    [75428:80864:0313/140904.131:INFO:CONSOLE(8)] "Uncaught (in promise) Error: ENOENT: no such file or directory, open 'C:\Users\tom\AppData\Local\Wappler\package.nw\css\style.css'", source: chrome-extension://fjjllfpmlaejicjkpknbdicdakiijgjp/Shared/DMXzone/dmxAppCreator/UI/styleEditorSimple.js (8)

#2

Hi Tom,

What is the project setting for the style file? The path and also the project root?
Seems it gets the wrong path.

Did you enter it by hand or used the file picker?


#3

Hi George,

I think you’ve found the issue.

I used the file picker. The path was: /css/style.css. Initially I set Links Relative to ‘Site Root’, but changed it to ‘Document’ (I wondered if this might be the problem). Having changed it to ‘Document’ I was surprised that the leading slash was still included. In any case it didn’t make any difference. I also removed the slash from the path in the settings.

Now I’ve removed the leading slash from the path in the file - and it’s working. Thanks.


#4

Good catch - @patrick will improve that in the next update


#5

This has been fixed in Wappler 1.9.4


closed #6

archived #7

unlisted #8

unassigned patrick #9