Database Custom Query "Request Failed: error,"

Wappler Version : 4.0.1
Operating System : Windows 10
Server Model: NodeJS
Database Type: MySQL 8.0
Hosting Type: Docker remote on AWS

I was expecting the custom query to execute in the Database Custom Query Modal, instead I got the following error:

The custom SQL executes perfectly in Navicat see below:

Also, if in Wappler, I fetch data from one of the tables subject of the SQL, I get the results as expected. So, Wappler can see and communicate with the database in the hosted container:

Please advise what I may be doing wrong.



For the sake of completeness when I try to execute a query with a very simple custom sql, I still get the same error:

Yet, I can fetch data from the queried table:

Is anybody else having problems Database Custom Queries?

Thanks for your help.



Hello, do you only have this error in Wappler - i.e, is the query working when the server action runs in the browser?
Do regular queries, created using the query builder work fine?

Hi Teodor, the query works in the browser and when the query is executed in the webpage. I guess the error is only the message in the modal for the custom query.



Please restart Wappler with logging, reproduce the error and click the submit bug report from the menu. This will open the log file location in the explorer so you can drag and drop the report here in this topic (no need to create a new one)

How do I start “Wappler with logging”?

Select “Restart with Logging” from the system tray menu …

Screenshot 2021-08-03 at 11.26.33

Sorry, I am such a newbie that I am embarrassed.
I restarted with logging, as you indicated, but I have not found “the submit bug report from the menu”. If you indicate me where this option and menu are, I will submit the bug report.

But don’t create a new topic, just add the zip to this one. And make sure to recreate the issue first of course!

OK, here is the error report: (79.1 KB)

Your report does not contain a log file, just a screenshot.
Can you please go to:


zip the file and attach it here.

I hope this one is OK. I just know enough coding to be dangerous! (5.1 KB)



Hm … in the debug log i see you are pasting a really strange value in the custom query input.
Can you please paste here the EXACT content you are trying to use in the custom query in Wappler UI?

Can you please remove the comments from this content i.e. all the

text here 

and try again?

Can you please try what I’ve suggested in my last post?

Let’s try again (78.2 KB)

Do I understand correctly that you removed all the


Part from the whole content you are pasting in the custom query and you still get the same error?

Correct, I removed all the comments from the sql script and I still get the error. See below how the new line 1 starts without comments, yet the error persists:

You also had some comments in the content, not only in the beginning - did you also remove them?

Yes, I removed all the comments