Connecting to AWS EC2 with ssh key


Just signed up for the 7 day trial yesterday. Spent most of my time trying to connect to AWS EC2 (Linux). After combing the forum, I didn’t find much so I started trying various things. My setup is an up to date win10.

Before continuing, please note that I’m new and never connected/worked with EC2 before. So there’s a good chance I’m not doing things the right way.

After reading the error log from various failed attempted connections it seems like windows or Wappler was trying to use files in the User .SSH directory. Which was odd… since I was explicitly attaching a .pem file (also tried .ppk file).

I also found that I had to press CTRL C to get past the password prompt in the Test Connection dialog.

So I went into the folder and looked at the files. It seemed to contain a private/public key pair from 2015. So I thought ‘why not’ and edited the files with my EC2 private/public content.

While the Wappler Test connection told me it failed the first time, the second time, it didn’t tell me it failed and the logs read success… so I closed the Test Connection and proceeded to change my Target from Local to EC2. From there, I was able to successfully upload files to EC2. But again, I had to press CTRL C when prompted for a password.

Hi there, sounds interesting, the strange ways you have had to use to get this working, can i ask what web development platform you used prior to Wappler if any. I ask because it sounds like you are using Wappler for the first time as well as AWS for the first time too, so i am wondering if you are fairly new to web development itself. If so, then for me, speaking from personal experience I would honestly look at the Apache / Linux platforms with a cPanel as a better starting point, considering probably 90% of us here are using some variation of Apache hosting, you would have a far larger user base pool that could possibly assist you when you come across issues.
If you are already a seasoned web guy and this is the way you prefer working then please ignore me, but if just starting out, and if there is no requirement for windows hosting, then switching may help before you get too far along.
Just my opinion

1 Like

Hey @psweb ,

Thanks for replying to my message. My web dev journey started in WP, then graduated to Bubble, and now I’m test driving Wappler.

The reason I’m using AWS is because I’m exploring building a HIPAA compliant application. To make a long story short… HIPAA requires a lot, starting with a HIPAA compliant hosting solution.

At this point, I’m looking into AWS Lightsail and the newly release Wappler Docker feature.

1 Like

Very interesting! I’m very curious how your HIPAA compliance goes.

Btw why did you chose AWS EC2? Will you be deploying your own docker containers on it?

Did you consider to use the AWS beanstalk?


I’ll definitely let you know how things go with HIPAA compliance.

Thanks for mentioning Beanstalk. I didn’t know that was even an option and after some research, it sounds like the best option given the ability I’ll be able to switch to a Docker once I have that up and running.

I’m now running into a different, yet connected issue. I previously mentioned that I need to hit CTL C whenever the Output window prompts for me for a password. As you can see from the screenshot below, when trying to Query the DB when testing the connection, I’m prompted for a password, yet am not able to hit CTRL C since the Database Connection window locked up the screen.

(I’ve hidden some fields in the screenshot, but the username/pw are entered correctly)

I’m thinking that were I able to hit CTRL C, maybe the connection validation would complete successfully. But I’m not sure.

That said, is it normal to have to hit CTRL C every time Wappler saves a file to the server?

No it is not. You should not have to hit anything except the save button. Please follow the reporting guidelines in this topic so the Wappler team and community can better assist you. How to report bugs together with the Wappler debug log