Changed theme color throughout site - but remains the same in 'theme editor'

Wappler Version : 3.0.3
Operating System : Mac

Expected behavior

What do you think should happen?

Nothing! I updated to 3.0.3 - I didn’t expect my ‘secondary’ color throughout the site to change.

Actual behavior

In the theme manager, the ‘secondary’ color is the same as it was previously, but throughout the site it is now a different color.

I’ve tried resetting the color, changing elements to a different color and back and nothing works.

This is still a bug, but for anyone that this has happened to this is how I fixed it:

  1. Go to theme manager
  2. Change the color entirely for the theme element (in my case ‘secondary’) and let it autosave.
  3. Change the color back to the original and let it autosave.
  4. Refresh the app pages.

That’s not really possible as the theme CSS file is only generated when you are actually using the theme manager and change/build it.

During the Wappler update none of this happens so probably you have changed something.

I definitely didn’t change anything. Changes were made to fix it, but otherwise I didn’t touch it.

Generally, the first thing I do when the site does not look like it’s suppose to is to clear my browser cache. It’s almost always that I am viewing a cached version of the site. Especially when it comes to CSS or image changes.

1 Like

Thanks Brad, if I was viewing the cached version then there wouldn’t have been any issues - as I haven’t changed the theme since setting the app up, but this wasn’t the case.

1 Like

@mgaussie, I too had the same reaction after the 3.0.3 update. I’m not certain if I did an upload before or after the update. I would guess it was after.

However, in my case, the client preferred the change. Haha!


@Teodor this has happened again, with this update.

Screenshot of the ‘border’ which has reverted to a dark color:
Screen Shot 2020-08-13 at 8.42.15 am

Then when you look at the actual border selection you can see it says ‘Secondary’:
Screen Shot 2020-08-13 at 8.44.06 am

Then looking at the theme for secondary, you an see the actual theme colour is a light grey (e2e2e2) and not the dark color that’s displaying on the actual site.
Screen Shot 2020-08-13 at 8.44.38 am

So what exactly did you do prior noticing this has changed? I can’t really recreate this on any of my test sites using custom themes.

In addition the ‘success’ color has also randomly reverted:

This is a login button that has ‘success’ as the theme color:
Screen Shot 2020-08-13 at 8.47.04 am

This is the selection:
Screen Shot 2020-08-13 at 8.47.57 am

And then when you review the theme you can see the color of ‘success’ is not reflective of the button’s current color. This is the old color.
Screen Shot 2020-08-13 at 8.48.33 am

@Teodor I don’t do anything. I have not changed the theme once (except to fix the issue last update). All the colors remain the same.

I then do the update, and suddenly the secondary and success that I’ve changed in the beginning of this project revert to the old color, even though in the theme manager they state the correct color.

Well have you tried clicking the “rocket” icon and then hitting the “upload theme” button in the Theme Manager panel? Also clear the browser cache after doing this.

Yes, of course - and when I fix the issue - these automatically save.

To fix the issue I have to change the color to something else, them back to the desired color and then save etc.

It’s really hard to check what’s going on as i can’t really recreate the issue on any of my sites.
What is your setup/server/target(s)?

NodeJs, docker, remote is digital ocean - this happened on my local machine - didn’t test on remote.

It’s easily fixed on my end each time so not the biggest issue - but probably shouldn’t happen - hence the bug report.

I’ve had this problem too and haven’t been able to work out what causes it but sometimes the project reverts back to the Bootstrap defaults and ignores my custom theme. Usually I just click the refresh or rocket buttons and it fixes it but sometimes it’s a little more resistant to that. The other day I uploaded the css file multiple times, kept refreshing, kept clicking on the rocket, opening the theme template file, etc. and eventually it fixed itself but this has happened a number of times. I thought it was only me so didn’t bother mentioning it until I saw this thread.


We will try to recreate this @George will check it as well.


yes same issue here.

Also I have been wondering why there are 3 buttons that seem to do the same thing, build, generate, upload. I tend to press all three until it displays the theme properly again.

Still happens to me each update.

I am wondering what you guys are doing. I cannot replicate the problem as you can see from the following video. At the end, I either upload the file or publish the site and all is well. If there are problems down the track, I have found these to be associated with the browser cache.

Edit: I see that I made a typo when entering the dark colour, this should be darken(#2b1d0e, 0.5)