Cannot connect to Microsoft SQL Server using DB manager

Wappler Version : 3.7.8
Operating System : mac
Server Model: php
Database Type: SQL Native
Hosting Type: custom

Expected behavior

DB Manager test should succeed

Actual behavior

An error is receive

How to reproduce

Test from Globals to SQL Server Native type:

Test from DB Manager using Microsoft SQL Server type:

This is again not really related the the SQL Native driver as it is in PHP server side only.

What you see in Wappler is an error connecting to your SQL Server.
Maybe you don’t have permissions to query the database? Or maybe our query is wrong, see:

You could try to execute it directly on the database? What you see in the error alert

I built the entire project in Wappler without any issue, so this is a new issue.

I can still today connect to the database using DataGrip and see all the tables, read data, etc.

I executed
select * from information_schema.tables
within DataGrip and receive the same error.

So DataGrip must not be calling that command, but Wappler is.

Well it is SQL Server version dependent and also permissions dependent - what version do you have?

And what if you try to execute it with uppercase as suggested, so:

select * from INFORMATION_SCHEMA.TABLES

Sorry, forgot to add that.

select * from INFORMATION_SCHEMA.TABLES

works from DataGrip.

Microsoft SQL Server 2016 (SP2-CU11-GDR) (KB4535706) - 13.0.5622.0 (X64)
Dec 15 2019 08:03:11
Copyright © Microsoft Corporation
Standard Edition (64-bit) on Windows Server 2016 Datacenter 10.0 (Build 14393: ) (Hypervisor)

Aha so that might be the problem then. Weird that it works with our SQL Server databases, but again different versions.

Could you send me maybe some test credentials in a PM, so I can connect and verify that it is working with my changes.

I have this problem too. Cant connect sql server from db manager. Any solution?

This will be solved in the next update

how can i get previous version of wappler? I have a project that must be finished today.

@nshkrsh Can you share the previous version?

what version do you need?

This has been fixed in Wappler 3.8.0