Bootstrap 4 Table generator produces wrong code on reapply

Used Operating System

  • Windows 10 Pro

Steps to reproduce (as an example)

  • Create a table using the table generator
  • Re-run the generator and make some changes (eg ‘striped’ or ‘hover’)
  • Result: various errors in generated code - usually a duplicate header row is created
  • Issue resolved by deleting files in cache folder

This is related to my reply to the Major Bugs in v1.0.5 thread. This is another problem which I had assumed was simply a bug, having experimented with the table generator many times over the last few days - it ‘reliably’ created errors in the code. Just now, for the first time, it worked perfectly: I could re-run the generator and make changes without errors in the code appearing. This was after I had deleted the cache files.


I don’t think this has anything to do with caches but it might be just a bug in the Bootstrap 4 Table generator.

Could you specify how did you call it for reapply? What was selected in design view and also in the App Structure? Maybe add a screenshot

Thanks George,

I was experimenting with the modal options again and made a demo showing the problem (separate thread). I think this is basically the same problem as with the Bootstrap 4 Table generator. However I’ve restarted Wappler and the Table generator is working at the moment. If it stops working, I’ll send more details in another reply to this thread.

I realise it would be useful to be specific but having spent quite a few hours working with Wappler recently, I think it’s a general problem. I assumed it was related to caches because restart or deleting caches etc. solves the problem, but only temporarily. I appreciate it may be nothing to do with caches, but it’s certainly a problem. I have avoided pasting in code or editing it - I’ve just been using the Wappler interface.

1 Like

For what is worth - caches are automatically cleared on each Wappler start. But those are just like web browser caches so they have no impact on the working of Wappler - just speed things up.

Thanks. But some problem occurs while you’re using Wappler, which can usually be resolved if you restart Wappler. Here’s another example:

I wondered if Wappler would work with the fairly ‘vanilla’ templates provided by Bootstrap. I pasted the source code in, removed any references to .js or .css files and applied the Bootstrap framework in Wappler. Worked fine - apparently. This is the result:

However, if I switch to code view:

Saving the file and viewing in a browser confirms that no code has been added.

Yes seems we have some syncing issues when editing a lot in code view and going back to design view.
We have tracked them down and will fix it all in the next update.

For now when doing major changes in code view - make sure you save and also when going back to design view, hit the refresh icon in its toolbar. Or even better close and reopen the page.

I’m glad to hear the issues have been tracked down.

Just to clarify a couple of points:
I wan’t doing any major updates - just simple pages, and making minor changes such as adding a class (via the interface). Most of the time the changes were made in design view, not code view. Finally, it was not just a matter of syncing: the changes which were apparent in design view were not actually written to the file. Viewing the file in a browser or closing/reopening Wappler confirmed that the changes had not been made.

We have many possibilities for adding classes - do you mean in the properties panel below the App Strcuture panel?

Or in the DOM Tree?

Also if you indeed were working only in design view and not switching to code view then you shouldn’t have syncing problems indeed.

That said - the initial topic about the wrong table generator reapply is just a problem with the table generator itself and the current selection.

Yes, in the App Structure panel, eg:

Also, making changes in the Table Generator dialog:

In each case (and others), the code either wasn’t applied or it was inserted into the HTML incorrectly.

This should now be fixed in Wappler 3.7.3

This topic was automatically closed after 43 hours. New replies are no longer allowed.