Argon2id Module Not Found issue

Sounds like a file may be missing. Try deleting the entire dmxConnectLib folder then open and resave a server action to recreate it.

Hi @Hyperbytes, thanks for the reply. i have tried it but no luck still the same error exist.
libs is the folder right? or dmxConnectLib? i dnt see that name, i only see libs folder.

here is the full error:

please have a look at this issue @Teodor

Yes, sorry. Quoted php solution, should be /lib folder
module should be under lib/modules/crypto.js

No problem, @Hyperbytes, crypto.js is there inside modules, but how that used in project? like script link or…?

Wappler should handle all that, it is called internally. think this is one for the team as I have no idea what is happening. Either that or try a reinstall of wappler as the error message indicates it may be missing from your wappler install

Do you have "argon2": "^0.28.3" in your package.json also have you tried to update node modules

its there, but node_modules folder not exist, seems like its needed right? npm install should be done to have those packages, but initialy i compare with my other nodejs project, they do not has node_modules folder either. basic project just created also same, no node_modules folder. i will get back with installing the packages and try

Just created a test project, initialy node_modules are not exist! is this correct? @Teodor

If you have selected to use the Wappler Local Server, no additional node_modules are installed but the Wappler builds-ins are used. I think we haven included argon2 there yet.

So choose to use “own server” which will use your regular NodeJS on your system and fully install all required node_modules, including the argon2 one if you use it.

1 Like

@George I see you still have not included Argon2 modules for the local server. Do you plan to do this in the future?

I think they were included in a past release.

Found it:

Nope, just created new project as Wappler local server and tried to use Argon. Module missing error.
easy fix, switch to custom, install node packages, switch back to Wappler Local server but certainly the issue remains

1 Like

Just double checked by creating a new project and trying to use Argon2id directly

I would move it to bug category then as they missed something when adding it.

Oh sorry was a Windows packaging problem. Will be fixed in the todays update

This has been fixed in Wappler 5.0.1

This topic was automatically closed after 46 hours. New replies are no longer allowed.