Android SDK does not get installed on a Mac

I have installed the Android studio as instructed but on the next check it says android sdk is not installed and gives a link to the same file I already installed?

Hi Brad,
Please check if you have installed an SDK in Android studio.

How would I check? I just followed the instructions in the terminal and installed Android studio as it said.

You might need to restart Wappler fully (do tray quit) to update the environment with the newly installed software so Wappler detects it

Noope, no luck ..... same error

Will investigate, try more the iOS integration on the Mac as it is beautiful :slight_smile:

Oh don't worry, I will. Just waiting for xCode to install on this computer. Then I will be bugging you with more dumb questions. :wink:

1 Like

I have the SDK installed now. Apparently it installs the first tome you actual open the Android Studio. So you have to run the studio at least once.

However, there is yet another error … terminal is asking me for a password for something?

Yes it wants to change the system path so android SRK is directly callable. Just give your local account pass

Adding “/Users/bradlawryk/Library/Android/sdk/tools” to the PATH…
Password: PasswordRemoved

bash: PasswordRemoved: command not found
Brads-MBP:test wappler app bradlawryk$ /bin/bash: echo /Users/bradlawryk/Library/Android/sdk/tools > /etc/paths.d/dmx_androidSDKtools: No such file or directory
Error setting PATH!

1 Like

Ah seems our functionally for altering the system path is not that smart…

Maybe try for now to add it manually, the Sdk bin folder, or wait till we fix it. Will also check if it is really necessary

I’ll wait until you fix it. iOS is more important to me at this point.

I am having the same problem on a windows machine. Message says “Android SDK not found! Please install it together with Android Studio!”
I have updated Android studio and the sdks and it works fine in dreamweaver with the cordova plugin.
Tried restarting Wappler and my computer.

We will soften those checks in the update for this week as we found a way to use the android SDK and studio better directly instead of relating on too many environment variables and paths.

That causes the current error because paths aren’t set.

I now have v1.1.2 and still getting the same error.

Cheers Mark

I had to actually open and run Android Studio once to get the full SDK to install.

1 Like

Yes indeed you need to run Android Studio at least once after installation. There you also need to install the needed Android SDKs and also Emulators you want to use

Yes, I have tried all that, including a system restart.
I do have DMXzone Cordova builder in Dreamweaver and that works fine.

Could you paste the exact output of the system check in the publishing panel?

Ohk here it is;

Checking NodeJS installation and version…
NodeJS is correctly installed.

Checking GIT installation and version…
git version
GIT is correctly installed.

Checking Cordova installation and version…
Cordova is correctly installed.

Checking Java SE JDK installation and version…
javac 1.8.0_162
Java SE JDK is correctly installed.

Checking for Android Studio installation…
Android Studio is correctly installed.

Checking for Android SDK …
Android SDK not found! Please install it together with Android Studio!
Please download and install the manually from: