Add Server Connect Component - Configuration Not Possible

Wappler Version: 2.5.4
Operating System: Mac OS

Expected behavior

When clicking the Add New Component button in the App Structure section, selecting Server Connect should show the Server Connect component and allow configuration.

Actual behavior

The Server Connect component appears only after clicking the “refresh” button, but does not allow configuration. Trying to save, then refresh / configure still does not work (options are not present). When options DO present, configuring the Server Connect component and saving still results in the Server Connect component either not saving entirely (e.g. the next refresh or exit/re-open) and or acting as if it was not configured in the first place and eventually disappearing from the App Structure UI.

How to reproduce

  1. Create a base app with text and forms
  2. Create a Server Action with Action Steps (in this case, I used an API Action)
  3. Create a new component in the App Structure by clicking the + button for Add New Component
  4. Select Server Connect
  5. Server Connect component initially doesn’t display
  6. Click the Refresh button in the App Structure pane
  7. Identify the Server Connect component and click
  8. Server Connect Properties don’t display, or, if they do, select an action and Save
  9. Refresh after a while and the Server Connect component disappears

Hello,
Can you make a small video showing the problem and post it here please?

It’s saying I cannot upload the video. Uploaded to iCloud:

https://www.icloud.com/iclouddrive/0U0TXn_XT01T_RtSlxemMUkaw#Screen_Recording_2020-02-10_at_11.07.51_PM

Please restart Wappler with logging, reproduce the problem and attach the debug log. See:

Can you also zip and attach your page here so we can inspect the code - probably there are syntax errors in the code.

I think I got it solved! When I add the Server Connect component within a section (e.g. not at the root under the App), everything seems to work fine. Weird, but works!