Zsh:1: command not found: docker

Wappler Version : 6.5.4
Operating System : Mac OS Sonoma 14.4.1 (23E224)
Server Model: Node
Database Type:None
Hosting Type:Docker

Expected behavior

What do you think should happen?

The server should be set up to run in the local docker instance.

Actual behavior

What actually happens?

Wappler is unable to find the docker command, even though I can access it through the Wappler terminal. I have demonstrated this in the video below.

I fully appreciate this has been raised a few times in this community. However, no real solution has been presented other than “re-install docker” via Homebrew. Unfortunately, I have docker set up for other projects and so re-installing is not a desired option.

Is Wappler using a different PATH value to run project services, compared to the one that’s being used in the Wappler terminal? If so, is there a way to append to it?

How to reproduce

Create a new Wappler project using Docker. When the project opens, it fails to start the service as it cannot find the docker command.

I believe this is a Mac only issue (user configuration, not Wappler) and can be rectified using Docker Desktop.

Thanks for pasting the above, however no matter where I appended the docker folders to PATH (.zhsrc / .zprofile), it still wouldn't work.

I did however found a solution, which was hiding on that page. I basically had to switch the docker install from User to System and then it picked it up. I'm guessing the Wappler nodejs service is running under a different user than my own? (which would explain why adding the docker folders to my PATH environment variable wasn't working?)

You can find the below at Docker --> Settings --> Advanced

1 Like