Zip an already created folder with Zip Processor how to

I’ve never used the Zip Processor before. What I want to do just is just zip all the files that are in a dynamic folder that has already been updated/created. Seems easy.

Is there any server prep to get the zip processor to work?

I didn’t know if the zip processor would only work when you are also using file upload component? Or it can be used alone? Or if there is a how-to somewhere, I wasn’t able to find one. I found some stuff over at DMXzone, but they all showed using the file upload.


Use Zip folder with dynamic path should work, no need for database connections (except if needed to get path)


No luck. I’m guessing it has something to do with that I still use classic asp…

I think you may need to have a load file step before the zip step.

right, I’m not uploading files though? they were already uploaded somewhere else.

Yeah I know, but even with a file upload action, you normally upload the file which saves it to the server, then load the saved file, then add whatever actions to the loaded file and save the file.
Because you are using a folder which I have never tried I am not sure but I would imagine it still needs to load something in order to process it.

EDIT: Im just trying it out for myself now, if I get it working i will let you know how.

great thanks @psweb

Ok got it working. It also had an error at first, but then i realised the Zip File which you named needs a path to know where to save, so try changing that to /assets/orders/

And you were correct there is no load step required for this at all, so i have an action with one step only called zipfile
Name: newZip1
Zip File: /imagesFolder/
Folder: /imagesFolder/testZipFolder

Saved the action and added at to my page as an auto load server connect command, on page load, it takes the entire folder called testZipFolder and creates a new zip file in the /imagesFolder/ called

When i download that file off my server and decompress it, the folder name of testZipFolder is not retained but rather the unzipped folder is also named myzip and inside it had all the files from the original directory.

what pre-proccessor are you using? PHP I’m guessing? I’m using ASP classic and guessing that might be part of the issue…

Yes, I’m using php I’m afraid, never really delved into asp too much, so cant really advise on that.

well thanks for the attempt. I guess I am gonna have to start learning PHP…
I’ve just done asp for so long its hard for an old dog to change tunes.

I understand that, I would feel the same about learning asp, however to be totally honest I have been manually coding in php for more than a decade, and with Wappler I dont think I use anything even remotely similar to an old manually coded line of php.
It helps having the background knowledge of the concept of what I want to do, like a repeat is a php loop as an example, but honestly I think you could change your server model to php and probably have virtually no learning curve at all.

back on topic, it looks like there is a zip.aspx, which is a .net extension? So maybe there is a config on the server that I missed? Or maybe some rights to use .net? Not sure

@patrick @teodor

I had overwrite and output both checked on mine, may be worth a try just on the off chance.
It does seem the initial error where it actually showed a path issue is gone though?

I had tried those options before, but went ahead and tried with them again. I think its a server config issue?

Maybe not , i am seeing issues on PHP also, investigating

ASP doesn’t support zip, the Zip Processor calls the ASP.NET version to do the work. The error seems to come from the ASP.NET page. Most common error is missing permissions, does the user under which .NET is running on your server have permissions to write to the folder?

Not sure I will check now.

seems like the all the users have permissions for this folder /assets.

IUSR and IIS_IUSRS have all rights except full control and the network service has full control.

Things like image upload and resizing all work for this folder.

.NET doesn’t run under IUSR or IIS_IUSRS, it probably runs under NETWORK SERVICE, what are the permissions for that usergroup?