Why does my MacBook Pro fan run constantly with Wappler 2?

#1

My 2017 MacBook Pro fan and Energy consumption is quite high when running Wappler. Any settings I can tweak to fix that?

#2

Usually the CPU and GPU usage with Wappler are very low. We have optimized for that.
But just like with the Chrome web browser - the more tabs (files) you have open and if they are video intensive, it will use more power.

If it happens all the time - maybe add a screenshot of the performance monitor.

Also make sure that it isn’t any other background task eating your CPU.

#3

MacBook Pros are inherently hot running due to very poor air flow (the fan speed will increase as will energy consumption), as you probably well know (also with the hot months now on top of us the ambient temperature is also up). I’d recommend a fan assisted laptop stand which may help a little… Certainly wouldn’t do any harm.

#4

That’s strange, perhaps something else is using lots of resources as well. I have a 2016 MB Pro w/touch bar and my fan never runs. Typically, I have Wappler, Chrome, Firefox, Safari, Outlook, Mac Mail, Skype and Tweetdeck running constantly.

09%20AM

#5

Seems better now. Rebooted.

#6

Happening again.

#7

26%20AM

#8

Does this help?

#9

I think issue is mainly when using my 4K external monitor. Is there a disable GPU option in Wappler?

#10

The issue seems to be when using external display at any resolution. Uses a lot of energy and fan run constant.

#11

May be of interest as it appears related (not a Wappler issue):

1 Like