What am I doing wrong? Bootstrap not rendering?

Starting a new site from blank. This should be easy as I have done it many times from beta version 1 to today. But for some reason Bootstrap is not rendering? Have I just been working too long today and doing something wrong? Here is a video …

whatswrong.mov.zip (13.5 MB)

Works fine if I choose CDN for Bootstrap … I don’t understand why it isn’t working for any local bootstrap settings?

Hello Brad,
Do you see bootstrap 4 includes in your code, when using local includes? Does this happen with bootswatch themes only, or also with local bs4 include option?

Seems all the files are being generated as they should. It renders fine in live browser. Just doesn’t render in Wappler Design View.

But do you see the bs4 includes in design view pointing to the right location?

Not sure what you mean by seeing Bootstrap includes in Design View? They are there in the code view and the page renders as it should in browser. All you see in Deign View is un styled elements.

Sorry I meant code view of course :slight_smile:

Yes it is properly placed in the code.

I got the same behaviour, but here’s how I fixed it:

When setting up your project (or modifying in the project settings) - make sure you have the web URL with the HTTP:// or HTTPS:// - once you modify that, new pages will have the Wappler interactivity and rendering working.

Just ran into the same issue, but the solution above didn’t help.

Blank nodejs project with BS5, tried to use a bootswatch theme and the page doesn’t render in design view. The layout file seems ok, therefore (I assume) looks ok in browser, but the page doesn’t render in wappler.

Not sure it is a bug or a feature, but the BS5 bootswatch themes are missing under Project settings/Frameworks. (added BS5 local instead, then added the bootswatch theme to the layout manually)

Tried to add the bootswatch theme manually to the content page, it is available, can see in code view that it will be included in the layout file, but when I save the file it disappears from code view?

The question is the same, what am I doing wrong? :slight_smile:

Any idea on the issue described above?