Webhook will not save

Wappler Version : 4.7.3
Operating System : MacOS Big Sur
Server Model: PHP
Database Type: MySQL
Hosting Type: LAMP

Expected behavior

Webhook should save correctly

Actual behavior

When I save a webhook it generates an error:
“Error saving file! Error during write to File: @@currentSiteRoot@@/dmxConnect/webhooks/Webhooks/test.php”

I have tried this in multiple projects all with the same result. It happened on 4.7.2 also before I updated and is still happening after the update.

How to reproduce

  1. In the Server Actions panel of Workflows add a new step to Webhooks
    Screen Shot 2022-04-13 at 9.53.12 AM

  2. Add a step and save
    Screen Shot 2022-04-13 at 9.54.15 AM

  3. I get this error
    Screen Shot 2022-04-13 at 9.55.05 AM

  4. My directory structure looks like this

Not sure how you added those webhooks but you have a choice first to use Stripe or custom webhooks.

Try to empty the webhooks folder and start again.

I did this:

  1. in a project that had no Server connect steps set up
  2. in a project that has other SC steps set up
  3. I emptied the webhooks folder
  4. I deleted the webhooks folder

In every case I had the same issue.

I do not have this issue when I create a new workflow in “API”.

I just added the webhook by selecting “Webhooks” and “Add new”.
Screen Shot 2022-04-14 at 9.37.38 AM

Based on the fact that no one else seems to have this issue it seems it is specific to my system and I can work around it by just using API and not using the Webhooks workflow.

Problem was in using the plus icon from the toolbar to insert main webhook types. It should be fine if you use the context menu.

Will be fixed in the next update

Fixed in Wappler 4.8.2