Wappler v5.4.0 broke website styles inside design view

It’s not just a NodeJS issue, same thing happened in all my PHP projects.

It happens in my node.js project. Wappler visualises the page with styles and suddenly as I made some modification sometimes show it like html 1.0. Also in previous versions
Then I must restart it to get the page properly shown

@george this is causing me problems too

I am working in a PHP with a head index page and lots of routes. Where route pages are in the root folder everything works ok. The content page references the head as ‘index.php’ and design view shows and everything saves ok.

When, however, a route page is in a subfolder I get issues. If I change the reference to the head page to ‘index.php’ design view works but it will not save as Wappler says it cannot find the head page. If I change the head reference to ’ …/…/index.php’ design view now doesn’t work but it will save.

I have site root selected in project settings:

Hi @george,
I have been trying to work on the project this most affects or me and it has been INCREDIBLY painful today.

Trying to manage it by constantly adjusting the head page reference is time consuming and a massive productivity killer. When you add some components (such as modals and conditional regions) the UI looks for the head page and when not found (because you have adjusted to make the design view work) it throws an error. Even worse was trying to add a where condition in a formatter for a dynamic class. The same error happened but then gets rid of anything you already did by closing the dialog. I am now working entirely in code view which is far from ideal - if I were a beginner to Wappler it would be unworkable.

This is a long-standing project that has worked fine for a very long time and has only ‘broken’ after 5.4.0

I see you and the team are team building next week. If you could find the time to address this with an inline update in the meantime, I know I would be super appreciative!

Please excuse me. I’m confused. I created a post with details for PHP. Maybe I shouldn’t have.

I think they should probably be merged - I suspect it doesn’t matter which server model you use; it is the same problem

I had this issue from day one using Wappler, 5.3.x, can’t remember. I actually created a couple of posts around as I couldn’t get pages in subfolders showing in the designer neither in BS or F7. All pages had to be at the root folder, so I assumed Wappler simply doesn’t support subfolders (changes to the head page, either from UI or code, didn’t have any effect)

With 5.4, it worked at least for me with BS 5 (purely frontend, no server), haven’t tried F7 yet.

Did any of you have the experimental features enabled and had these problems before? With 5.4 we moved an update for design view out of experimental.

With the next update we will have some minor fixes, not sure if it will solve the problem for all. I was able to reproduce the problem with a PHP project which will be fixed in the next update, wasn’t able to reproduce it in NodeJS but it seems to be related and the fix should also work for some NodeJS issues.

The main issue with the design view not rendering is the resolving of the paths, to have a better overview when it goes wrong please tell the following:

  • Where are the files located (main and content page), are they in a subfolder
  • What is the setting for links, relative to site or document
  • On the content page how is the main page linked, looks like head-page="layouts/main"

I think I had experimental enabled (accidently). From what I can see now, changes to head-page work for me now (just tried two projects and also fiddled around with the F7 Kitchensink by adding the Wappler commen to the subpages - which made the designer work as expected)


Experimental on, PHP project includes files lost styling (in directory named includes within site root), site set to document relative.

Looks like you already found the issue.

Appears the same issue also occurs on the new project dialogue.

Not sure what you mean here? What’s wrong exactly with the dialog or thumbnails?

The images for the projects do not display and wondered if this was a result of the issue? They used to display fine prior to the last couple of updates.

Screenshot from 2023-02-14 19-32-28

Fixed in Wappler 5.4.2

1 Like

This topic was automatically closed after 32 hours. New replies are no longer allowed.