Wappler using proxy on Linux

OS info

  • Operating System : Linux Mint 19.1
  • Wappler Version : 1.9.7

Problem description

Impossible to connect to api.waappler.io/login with Wappler application : i’m on an intranet network and i’ve put in system proxy’s in order to go out of this intranet and so, on internet. It work well with other application, nut not with Wappler
Is it possible to have possibility to configure proxy in Wappler ?

Steps to reproduce

Hi Thierry - welcome to Wappler!

Wappler usually uses the system wide proxy if one is specified.

How have you defined the proxy in your Linux Mint?

Also where do you see the connect error? Maybe you can provide a screenshot?

Here is my configuration :

thierry@thierry-ThinkCentre-M83:~$ env | grep proxy

It’s strange in effect !

How did you enter the proxy info?

I just tried in Linux Mint in the settings/network:

and it worked all fine. Proxy settings are picked up automatically by Wappler


Sorry for late in answer, but proxy system is nice for other application; here is what i have with Linux Mint :

I’ve tried to put proxy ip address on my connexion as well, but i allways can’t open Wappler at work and behind a proxy.

Is there option somewhere in Wapple to debug network or in order to force ip proxy ???