Hello, I’ve got a problem with Wappler’s timestamp configuration.
As seen on the image, the correct timestamp is the MySQL one, witch is my region date time (Buenos Aires, Argentina). Wappler’s time is 3 hours later.

What do you call Wappler timestamp? What value are you inserting in your DB?

1 Like

Looks like that time stamp may be UTC not local. Are you inserting NOW_UTC by any chance?

1 Like

I’ve been using NOW. Nevertheless, I solved it by subtracting by 3 hours Wappler’s timestamp

why not set it at server level using timestamp as a field default

Because it’s a calculated value. The serverlevel timestamp works fine. The one with the issue it’s a calculation betweeen the current time and the token expiration, so current time + token duration (1hour for google api services) = token expiration

1 Like

The NOW used by Wappler query builder is not the MySQL now, it uses PHP to get the current timestamp. So I think that your PHP is configured in a different timezone then your database.

1 Like

Any resolution or advice on this. getting the same 3-hour difference. Subtracting is not an option.

Why not use NOW_UTC and convert to users time zone?

1 Like

If you are looking for a resolution on server-side, see the marked solution by Patrick. Its server configuration that needs to be set. Does not look like a Wappler issue.

If you are looking for a resolution on client-side, Theodor’s answer should work for you.

@Teodor This worked