Wappler CPU performance on Mac

I constantly face cpu performance as well – iMac 8 core i9, 32GB ram and 8GB graphics.

I’ve never been able to submit an actionable bug though. :frowning:

I am very familiar with the restart wappler option unfortunately.

1 Like

A big update is coming up tomorrow, we are updating the core to the latest Chrome 85, which has huge performance improve ta and lot of less memory usage!

So let see if that helps :slight_smile:

4 Likes

Installed 3.3.1 and I am really sorry to say that things got worse… When using Wappler:

Screen Shot 2020-09-11 at 20.44.31
After a few minutes it gets reaaally slow and freezes.
Sorry to ask, but is there a way I download the previous version so I can downgrade?

What kind of page do you have open that is causing so much cpu, maybe try another or none at all for the test

Do you have an Antivirus for your mac? Are you using an external monitor? If so what A/V output are you using?

Page I have open is a regular PHP file created in Wappler. Nothing fancy.
If I switch to a completely different project it behaves the same.
When I close all windows (within Wappler) it remains at 130% CPU for NJW helper (renderer) and Wappler itself at 0.1%.

Not using a monitor, just working directly on my Macbook without external keyboards or mouse. No antivirus that interferes.

That’s a shame because it had an easy fix :slight_smile:

I was having a lot of performance problems due to docker desktop for mac(already mitigated in latest versions of Docker), using AV software and changing from hdmi to displayport.

1 Like

try closing Wappler completely (right quit from the icon in the system menu above) and make sure no other nwjs Helper processes are running on the background. Then start Wappler again.

It might happen that you have a runaway background process called nwjs Helper - that is somehow remaining of previous instance - and that is sucking the cpu.

I am having issues as well. It takes me now 8 seconds (which was nearly instant prior to the release) to display the results of a simple search on table. In browser mode it renders the results instantly. (Using Docker locally). Using the View Toggler, in Wappler, it takes 8 seconds for something that was rendering instantly prior to the new release. I am on a Mac with the latest version of Catalina. Below are my screenshots of the CPU and Memory of nwjs. I took these screenshots after quiting Wappler and restarting. Note: All nwjs CPU and Memory processes ceased after I quit Wappler.

CPU Screenshot:

Memory Usage:

OMG what the hell are you running that needs 40 gigs of RAM?

:)) 40GB really good

LOL. Docker, Wappler, Notes, security video, Dropbox Accounting, financial apps, a bunch of browsers, Windows 10 with some apps, and 3 monitors on my Mac. LOL

1 Like

I’ve done this and did a full reboot ensuring no nwjs processes were running. As soon as I fire up Wappler, same issue.

So even without doing anything in Wappler it uses so much cpu? Without any open editors?

If so maybe try a full clean install as described in

I did a full clean install as per your suggestion, same…

When I close all windows (within Wappler) nwjs Helper drops to 12% CPU. As soon as I open a window and start working it goes back to 120% CPU. When I switch to the browser (hence not using Wappler), still 90% CPU…

Do you need some further data to investigate this issue?

Does it stay constantly at 120% even if you don’t do any thing on the page?

What about different pages?

Tried different pages and different projects. Doesn’t seem to be content specific.

Even if I don’t do anything, it remains really high, between 90 - 120.

Well I’m not sure what is up with your Mac.

I’m working on Macbook Pro from mid 2012 and Wappler’s nwjs processes doesn’t go above 5% when idle. When working and opening new pages, they spike a bit to 50% but quickly return to 5-10%

What is your system configuration?

1 Like

Have you tried running it by loading macos in safe boot? I am pretty sure it’s some other process interfering with it.

1 Like

Yes I started to think the same and in safe-mode it didn’t happen (good suggestion).

Cleaned my system (using OnyX) and it seems to be back to normal… AND is indeed less CPU intense than version Wappler 3.2, as promised :slight_smile:

So seemed to be my bad, apologies. Really appreciate your support and thinking along though, especially in the weekend!

2 Likes