Validation issue

#1

I’m using this validator but it’s not fully working. I’m using it to check for an existing username. If I enter one that exists, the form doesn’t submit (correct) but there is no message displayed. If I change the username to one that doesn’t exist, it inserts the record but shows the message ‘that username already exists’. Is this a bug? I’m running v2.0.0 (I’m updating every time a new version comes out).

Check if a Database Record Already Exists Before Inserting a New Entry
#2

I think we can be pretty sure that this is not a bug as this is a well tried and tested component.

Maybe this thread may help as it discusses similar issues. If not we need more information to diagnose the problem.

#3

Thanks @Hyperbytes. After a lot of debugging, I’ve found the issue.

In the Server Actions, the Validate Data action must be above the Database Insert action. Moving it up one position has fixed it.

#4

Hello @sitestreet,
Yes the validation which checks if the record exists in the table you want to insert the record must always be before the I sent step :slight_smile:

1 Like