V5.2.3 - Parallel Group in Server Connect is not working

Project: NodeJS, MySQL, Local Docker, MacOS

I upgraded Wappler to v5.2.3 today and noticed that all API actions within the Parallel group - Database Queries & Set Values, have stopped working. If I remove the Parallel group step, these queries start working correctly.

I have attached a screenshot showing how the Parallel groups have been setup in the Server Connect. The queries run correctly up to the Repeater rpt_vehicle_id, and returns no result from the APIs within the Parallel groups.

Not sure whether it’s a new bug in the latest version or my setup is wrong. Any assistance to resolve this issue is greatly appreciated.


I reported a bug due to unstable scope in 5.2.2 and a fix was released in 5.2.3:

In your case, I verified the issue to be a missing “Name” in your Parallel step. I’m tagging @patrick because this fix caused a behaviour change in your application

Thanks @Apple for verifying this issue. When I add “Name” in the Parallel steps, the results are being returned correctly. However, data in the AppConnect is still not appearing. I have tried adding name of the Parallel step as a prefix in the AppConnect queries and it’s still not working. And again there will be many places this modification will be required in the UI code if name is required as a prefix.

Let me know if this fixes the issue.

core.zip (2.0 KB) unzip to lib/modules.

Hi @patrick, thank you for an updated file. I’m afraid this hasn’t fixed the issue. The result set from the query is now like this:

  1. Repeat step - No output of any included Output Fields from the repeat expression
  2. Only first query in the first parallel exec step is returning the data, no data result for the other queries and the second parallel group

New update: core.zip (2.1 KB)

Thanks for an updated file @patrick, the Parallel steps are working correctly now. I have tested a few APIs and all are returning the results as expected.

Thank you for a prompt fix for this issue :+1:t4:

Fixed in Wappler 5.2.4

This topic was automatically closed after 47 hours. New replies are no longer allowed.