User Group Registration

I am new to wappler and have very limited coding experience. I have been able to successfully create a sign up and log in page thanks to the multiple resources on here - thanks especially to Ben!

My intent is to have users sign up, via email/password or 3rd party API (Apple/FB/Google), creating a User ID. After successfully signing up they are directed to a “register” page where they register as 1 of 3 groups; business, customer, business associate. The intent is once they submit the registration form, they are added to the specific group table, along with their User ID generated in signup. I have scoured this community and the internet for days now but have not been able to find anything that outlines this.

Currently the order of operations is:
Form button is clicked to submit > Following API Executes > Database Single Query (to obtain User ID) > Database Insert (to insert form data into new Group Table)

I know this is wrong but I can’t figure out the step needed to place the db query into the dbinsert.

Thank you very much in advance!

You just open the insert, on the value hit the lightning bolt and choose the bind from the query:

Also you can get the user id using the security identify:

1 Like

Using the security feature worked, thank you! Now my only problem is getting the data from the form to input, which doesn’t make sense to me considering I’ve had good success with server connect forms.

I know I thought I had fixed this but it is continuing to occur. The data I am inserting into my form is not populating in the db.

Could you maybe post a few screen shots of how this is setup this could be something as simple as the $_POST variables don't match either in the form (each input has a name), in the inputs on the server action or the actual insert etc. Is the form set to POST and not GET?

Also check for errors using:

1 Like

I have double & triple checked the value is linked to the post value. I tried to “humanize” the first and last name thinking that may have helped - it had no effect.

This is what my db insert is:

This is the error in the debug.

I will go thru the form now to re-verify the input names in the form. What is odd is it briefly worked the other day. Thank you for your help again!

Could you please check the link I sent this is the file that throws the error. Using browser tools and going to network XHR selecting the action and choosing preview will show the actual error message

Sorry, duh! I’m embarrassed LOL You were correct, the text input names did not match. Thank you!