Unknown component found! Autocomplete

PLEASE DELETE THE BUG TEMPLATE DUMMY TEXT BEFORE POSTING THE TOPIC!

Thanks for reporting an issue! Spend 60 seconds reading this…

  1. Before reporting, make sure you have the latest version of Wappler.
  2. Make sure you have searched the forum first for similar issues being reported
  3. If it is a general web related issue - do a Google Search first
  4. Issue tracker is only for bugs and feature requests, in English only.
  5. Learn how to report bugs effectively

======== TEMPLATE BUG FORM ========

Wappler Version : 6.5.1
Operating System :MacOS and Windows 11
Framework: Capacitor with 8.3.0

Expected behavior

What do you think should happen?

Creating autocomplete field should add the autocomplete component and create the corresponding link entry in the head section.

What actually happens?

The component is added to the project but the link entry is not added to the head section. Wappler says it is adding the entry but it in fact does not add it. Adding the script src entry to the head section manually does allow the component to function normally.

How to reproduce

  • Detail a step by step guide to reproduce the issue
  • A screenshot or short video indicating the problem
  • A copy of your code would help. Include: JS, HTML.
  • Test your steps on a clean page to see if you still have an issue
  1. Start a new project and switch it to Framework 8.3.0
  2. Create a list and add a form field.
  3. Convert the form field to an Autocomplete

index.html.zip (308 Bytes)

Could you try with the latest Wappler 6.5.2 - as to me it works fine with it, so maybe the problem is solved.

I'm having the same issue - I've tried turning my text input into an autocomplete, and got the same error.
Then tried switching it to a Tagify element, and now getting 'Tagify not found'.

Details: I'm on the latest update of Wappler, on Mac OS, using Node.js.

I'm pretty new to Wappler, so hadn't used either type of component before.
Got all the messages in Wappler saying it had added those scripts to the head when I first converted the inputs, but it doesn't seem to have actually done it when I check in a local browser...

This is a screenshot of my current dmx components (which is where I believe autocomplete/tagify should appear?):

... and all the scripts in the head:

I've tried 'switching it off and back on again'. :wink:
Full disclosure - I may just be doing something daft. Apologies if so!!

LOVING Wappler btw - thank goodness I found this and didn't stick with Bubble!!

1 Like