Unformatted browser view

Hi All, probably a simple/dumb question but I just tried deploying a test page to my browser and no formatting was applied. I saved the .ejs files, deployed to Docker Desktop, then opened in Chrome.

Wappler view:

Chrome view:

I suppose the css stylesheet isn’t being applied correctly, but not sure what I’m doing wrong.

Does the index page have a layout page associated to it?

Welcome to the Wappler club :slight_smile:

This is how I would troubleshoot:

  1. Check which stylesheets the page is loading:
    right click → page source
    Ctrl F “.css”

What do you see? I’m guessing you’re missing the bootstrap css file since absolutely no formatting is applied.

  1. If you don’t see it, then go to your layout page, that’s where your is. So check which layout page is associated like @bpj said.
    Then the problem might be fixed if it’s simply not linked to eachother.

But if they are linked to eachother…

  1. Keep your layout page open, use the button on the top right and add one of the bootstraps.
    Save your layout page and check if it’s fixed.

Thank you @karh and @bpj! I used your suggestions to work it out - had to create a new layout page and link that in - then it worked :slight_smile: Enjoying the Wappler community as I learn how to use it - people are so helpful!

1 Like

Glad it’s fixed :slight_smile:

Some more tips on where to look when you have layout pages issues:

On your content page it should be included in the ‘app properties’(1), and you should see this in the green code (2) with your layout name, not my ‘adminLayoutv2’

And secondly, in the ‘routes’ panel when you go to the route that loads your content page. You should see it included there as well:

1 Like