Unable to start a mobile project - npm permissions

I’ve tried several times over the last few months to get started on a mobile app but I just can’t get past the initial setting up. I’ve just tried again with v2.1.0 but still getting errors:

The final part of the terminal has this:

npm ERR! notarget 
npm ERR! notarget This is most likely not a problem with npm itself.
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn't exist.
npm ERR! notarget 
npm ERR! notarget It was specified as a dependency of 'cordova-lib'
npm ERR! notarget 

npm ERR! Please include the following file with any support request:
npm ERR!     /Applications/Wappler.app/Contents/Resources/app.nw/npm-debug.log
Cordova installation failed!

I can send the log file if that would be helpful.

Any ideas? I’m on a Mac.



Make sure you have the latest nodejs installed and also Cordova 9

How do I do that? Is there a doc for that? I thought Wappler came with all those frameworks.

I’ve had a good search and I can’t find out how to install nodejs and Cordova 9.

Just go to:

download and install at least Node 10. make sure you fully restart Wappler afterwards.

To update Cordova, there is a Cordova update button in the publishing toolbar in Wappler.


To check the version afterwards, run the system check from the same toolbar.

Thanks George.

Node.js and Cordova are now both installed. It’s now giving me an error saying ios-sim is missing. I’ve run this command:

sudo npm install -g ios-sim --unsafe-perm=true

and it says it’s installed successfully but every time I select the iOS platform, it does the checks and says it’s not installed.

Is there a comprehensive list of the process that needs to be followed to get mobile app developing up and running?

Make sure you have run Xcode at least once and downloaded any tools it wants.

Also after installing global components with sudo, make sure you fully restart Wappler, or logout/login on your Mac

Thanks George. OK, I’m getting close, I think!

Xcode has installed various bits but I now get this in the terminal:

Using cordova-fetch for cordova-ios@^5.0.0
Failed to fetch platform cordova-ios@^5.0.0
Probably this is either a connection problem, or platform spec is incorrect.
Check your connection and platform name/version/URL.
Error: npm: Command failed with exit code 243 Error output:
npm ERR! path /Users/jon/.npm/_cacache/index-v5/6c/ec
npm ERR! code EACCES
npm ERR! errno -13
npm ERR! syscall mkdir
npm ERR! Error: EACCES: permission denied, mkdir '/Users/jon/.npm/_cacache/index-v5/6c/ec'
npm ERR!  { [Error: EACCES: permission denied, mkdir '/Users/jon/.npm/_cacache/index-v5/6c/ec']
npm ERR!   cause:
npm ERR!    { Error: EACCES: permission denied, mkdir '/Users/jon/.npm/_cacache/index-v5/6c/ec'
npm ERR!      errno: -13,
npm ERR!      code: 'EACCES',
npm ERR!      syscall: 'mkdir',
npm ERR!      path: '/Users/jon/.npm/_cacache/index-v5/6c/ec' },
npm ERR!   isOperational: true,
npm ERR!   stack:
npm ERR!    'Error: EACCES: permission denied, mkdir \'/Users/jon/.npm/_cacache/index-v5/6c/ec\'',
npm ERR!   errno: -13,
npm ERR!   code: 'EACCES',
npm ERR!   syscall: 'mkdir',
npm ERR!   path: '/Users/jon/.npm/_cacache/index-v5/6c/ec' }
npm ERR! 
npm ERR! The operation was rejected by your operating system.
npm ERR! It is likely you do not have the permissions to access this file as the current user
npm ERR! 
npm ERR! If you believe this might be a permissions issue, please double-check the
npm ERR! permissions of the file and its containing directories, or try running
npm ERR! the command again as root/Administrator (though this is not recommended).

npm ERR! A complete log of this run can be found in:
npm ERR!     /Users/jon/.npm/_logs/2019-06-15T13_55_39_561Z-debug.log
Error adding ios to your Cordova Site!

Of which action is this the result?

Seems the command needs to be prefixed with sudo

This is when I select ‘iOS ^5.0.0’ from the Platform menu. It says the platform is not installed for the current Cordova Project, would you like to install it now? I click ‘Yes’ and get that output in the terminal.

hmm weird. Did the Cordova upgrade went all well? How did you updated it?
Also what the system check now shows as versions of Node and Cordova?

I used the ‘Cordova Update’ button in the toolbar to update it.

The system check shows this:

Checking NodeJS installation and version...
NodeJS is correctly installed.

Checking GIT installation and version...
git version 2.13.6 (Apple Git-96)
GIT is correctly installed.

Checking Cordova installation and version...
9.0.0 (cordova-lib@9.0.1)
Cordova is correctly installed.

Seems you have some general node permission erros.
To fix see:

YESSSSSS!!! That’s fixed it. I think I’m up and running.

Thanks George.

Do you have a help page which gives all this process for new setups? Everything relating to mobile app development seems to indicate it’s a one-click process.

Yes once you have it all running, it is pretty much one click.

Check the docs to be sure:

and also the dedicated Cordova docs for more info on the publishing process.
For all the different platforms:


1 Like