Unable to Create Database Connection in NodeJS in Server Action

Hi,

I updated my Wappler to 3.4.0, created a fresh new NodeJS project, added GitLab as per the new stuff, published my NodeJS app to dev server - and everything was working fine so far.

Next, I created a new server action and tried adding a new database connection. But this what I see:


The two buttons - “folder” & “link” are not visible.

I tried creating a connection in the DB Manager UI, and clicked the “server connection” button, and it returned a completely blank popup with just a save button.

Please help. Need an urgent fix. I am unable to proceed on my project without this.

P.S. Don’t know if this is a bug since this is the first time I am trying DB connection with NodeJS.

Well you need to define your database connection in the database manager. Then it will become available…

Has this been the way in NodeJS always or only in 3.4.0?
Because in PHP/ASP, I have never used DB Manager.


Added in DB Manager.


This is what I see on click of “Server Connect Connection”.


No change in the server action.

@Teodor Were you able to replicate this?

@patrick / @George please help.

This is how you set up database connections for NodeJS since its been introduced in Wappler.
For PHP/ASP it’s different.

You need to click Server Connect connection and set it up:

Then it appears in your server action:

Also, there is no need to make a new post every hour tagging different people. It’s Friday evening here in Europe, after our working hours, we are not 24/7 available in front of our computers. Please be patient, we will answer your requests …

1 Like

Clicking server connect connection kept showing me blank pop-up, as I shared in above post.

Its even late here. 2200hrs IST. But when work’s important, I like to try everything I can.
And I replied to you within 2 minutes, so was waiting for an answer. Maybe you got busy in those 2 :sweat_smile:

Trying “Server Connect Connection” worked this time and was able to setup my server action correctly.
Although, I got a 500 error saying db_dev.json not found in modules folder. So had yo upload that manually. Is there a step I missed here?

Is there a help doc for this… I could not find anything. Can you please share a link?

I was walking down the streets of Sofia, heading home actually :slight_smile:

Never seen such an error before. Maybe you can share some screenshot?
So is everything working fine now?

Will have to delete the db json file from server. Let me try.

Yes. :smiley:

Remote File Structure:
image

Error in browser:
image

Uploading manually from local, gets rid of it and fetches data correctly.