Unable to connect to remote mysql database: 404 Error!?!

#1

Hello there,

I’ve read the previous posts on this matter and sent support request to the hosting provider…but no solution so far.
I can connect to MySQL via DbVisualizer, using the same connection parameters. However, wtih Wappler I got the following in response:

Is anybody willing to help me out with what’s wrong with this?

Thank you, appreciated.

Mag

#2

Hello Mag,
This means that either the site url or the remote folder in the selected target configuration are wrong. Please double check this.

#3

Adding to @Teodor’s reply, you may ind that the Server Address should be the default localhost. Please check with the service provider.

.

#4

Thank you for your quick replies, both.

The target configuration seems to work fine. I connect and upload Wappler files as needed.

Regarding using ‘localhost’ as server address in the database connection, it does not change the response:404.
I get the same response even inputting the minimum required info:
Server address: localhost
Database: database_name

It’s not a server or permission issue because Db Visualizer connects me without issues.

Eventually, it’s me configuring the target or Db connection wrongly in Waggler, but cannot see where.

Thanks!

#5

Hello guys, I’ve checked with the hosting provider and everything is fine on their side.
As I cannot solve this, I’ll try a bit more then I’ll ask George a refund, as I don’t have any use for Wappler, given the impossibility to connect to the db.

All the best.

#6

@magdy.reda
The error you see means something in your target config is wrong. So the script looks for the files on a wrong location because of that, and it cannot find them there - that’s why you see the 404 error.
Please try leaving remote directory empty - that could be it, or the target url is wrong, or you need a remote directory like public_html etc. - check this please.

#7

Could you just click on the “test connection” button and see what the output is?

#9

It could still be a server issue. If you are using ModSecurity, Imunify360, or CSF, any of these could be causing issues and may require changes to rulesets. Please check/view your log files.

#10

George, I spent a couple of weeks with the web hosting support and they really couldn’t help. I connected to MySQL successfully with DB Visualizer, DBeaver, and others.
The FTP connection is just perfect. It’s just the DB connection that gives problems.

The text connection responds as posted above:

Error using this Database Connection!
Server Response: 4040 Error @media screen and (max-width:500px) {body { font-size: .6em;}}
Sorry, this page doesn’t exist. Please check the URL or go back a page.
404 error. Page Not Found.

As it’s a 404, it is connecting to a web server and not to MySQL, of course. The web hosting might not be the best around, still it’s classic cPanel and MySQL staff, and all security settings have been stopped to be sure that these are not interfering with my connection test.

#11

Hi Magdy,

You probably have entered wrong remote URL or Remote Folder.

That is why we have the “Test Connection” button in the target settings. Please use it.

#12

Thank you for the quick reply George. I’ll do my best :wink: