Traefik

Hi

I’m having a bit of trouble with Deploying Traefik for SSL it seems that it won’t generate a cert or configure the routing to the web container on docker deployment to either DO or Vultr.

Server logs don’t appear to show any errors

Attaching to wappler-compose_portainer_1, traefik
traefik | time=“2021-04-07T07:42:13Z” level=info msg=“Configuration loaded from flags.”

Redeploying the container doesn’t seem to work either

Any insight would be welcome

Just out of curiosity has anyone tried Caddy with Wappler yet?

Its okay I managed to resolve the issue.

I finally ended up defining all the parameters both in my dns settings and in the wappler settings before it would start to try to define certificates and then had to also change the url to be the site url of https://mysite.com on deployment.

When That was all done Traefik started to work okay.

orginal issue.

didn’t define portainer url or a secure traefik url but did remove port and left the site default to the ip address.

resolved by

  • defined specfic A records for portainer traefik and the website.
  • set the webserver location in node js section of target to “https://www.mywebsite.com
  • Set the server to use portainer and traefik and defining all the parameters in those url and user id and email.
  • applied portainer and traefik to website
  • deployed the website to the target environment.

Thats a bit more than I had to do with previous versions could this be an issue with the default traefik image of 2.2 now that its up to 2.4?

Do you mean that you didn’t had your DNS setup at all beforehand to point to your server?
Pointing you domain name to your server ip is a logical first step naturally …

1 Like

No George I did have the DNS configured correctly. But was using a * wild card cname for the other domains such as portainer.mywebsite.com and traefik.mywebsite.com it didn’t like those until I did an A reg for each. I know I shouldn’t have had to do that but for some reason it just didn’t like it.

Hmm normally a wildcard should do just fine.

Wild card cnames always had worked when I used them before. What was interesting in this behaviour was that it is the first time I used node 14 not that that should make a difference. and the logs showed it didn’t start even going out to the acme server until I had configured everything in wappler. Even after leaving it for an extended period of time. In the end I had configure the the portainer url and the traefik url before I would even get errors. Then until I created unique records it returned that it could not find the urls in question.

Interesting though it was I eventually got a working version and that was all that mattered.

And I still love wappler.

Well node version shouldn’t matter at all, as traefik is running in its own docker container handling everything about SSL issuing on its own. And it acts as a router(proxy) eventually passing the requests to the node web server internally.