Traefik ssl certificate not generated

Hi all,

I have just setup a live server and added Traefik and Portainer but I am not getting an SSL certificate for the site.

I have in the project production target and both traefik and Portainer are accessible with a valid SSL certificate (using a sub domain *

Unfortunately when visiting an API endpoint or page I get a 404 error (both with https and without)

I have deployed the server and app a few times but I have noticed that in Portainer the app _web and _db containers are in a different network from the portainer and Traefik containers. In a separate, older project all 4 are in the same network.

Could this be the problem? Any thoughts on the best way to fix this?

As an update, I tried to remove Portainer and Traefik within Wrappler but they didn’t get removed from my server, so I put them back :slight_smile:

Also tried moving the _web and _db containers to the same network as Traefik (via Portainer) but Traefik did not get an SSL certificate and when I deployed my project again, Wappler moved them back to their own network.

Ok, tried again this morning.

Removed the live server completely.
Created a new live/production server through project setting > targets.
Added traefik and portainer via the project settings method rather than the new resource manager and now everything works.
I can’t point the finger at resource manager over project settings methods since I assume they use the same process but I am used to the “old” way of doing it so just happy it all works now :slight_smile:

I’ve been trying SSL on AWS for 2 days and it won’t
@George what am I doing wrong?

Click on the logs icon to see the error logs