SQL Server Query not returning results

Running a query against the local database returns no results. From what I can tell it appears the db gets no request.
What could be stopping the request from reaching the db?

Can you expand the output to see the exact content returned?

Also did you toggle the output option on the query? But not the debug option - as when debug is on no results are returned but just the query

Yes the output is on, the debug is off, thanks.
Here is a screenshot showing the page and also the response tab:

I load the page, open the developer tools, then refresh a few times while watching the SQL profiler and nothing seems to be making it through to the sql server

In contrast, running the same query (from my Visual Studio app) appears in the Sql Profiler like this:

I can see the SELECT statement coming through, and the results after it.

For completeness, here is the Wappler query on the same table-nothing tricky here:

If it helps, here is the IIS server log–the request from Wappler is there and response code is 200…it looks ok:

What is the query you are running in Wappler’s database query builder?

Can you try to add just an “Set value” action step and give it a name and an value with output on, to see if you action is running at all as I have a suspicion that aspx pages just don’t run at all.

The query is:
SELECT * FROM “dbo.Inboice.FunctionCodes”

I did a Set Value and nothing was shown in the browser:

And still no output? If that is the case your server isn’t running asp.net files. So you should check that.

So check the asp.net is installed correctly and running. See

Everything seems to be working.
Is there a set of guidelines as to where to create a Wappler app under IIS?
I’m out of ideas for now.

I’ve worked for a few days trying to get Wappler to display an aspx page with no luck.
First I created a simple single-page in Visual Studio, it runs and displays fine after making some changes to its web.config file.
My local IIS server runs aspx pages without issues.

I created a test page in Wappler, and made similar changes to the Wappler web.config file.
Attached are screen shots showing a simple page with one textarea with static text,
and the resulting display in Chrome–nothing. It’s empty. Maybe I did something wrong on the page?

What is required to get Wappler to display a page with text on it, running under IIS? There must be some kind of configuration issue but I have no way of knowing what Wappler is looking for–simple pages made in Visual Studio run fine.
Is there a simple Wappler test case I can put together?

Thanks for any help

Got the aspx page to come to life, but now getting a connection error, any ideas how to resolve it?
The “records” file seems to throw a null error.

Is this a bug?
Digging through the connection files and found this discrepancy:
The connection name should be ‘dbConn’.
File path: …\App_Data\ServerConnect\modules\Connections\dbConn.aspx

This connection name is correct:
File path: …\App_Data\ServerConnect\modules\Connections\dbConn.json

Background: when originally setting up the connection I used the name ‘devConn’, then changed it to ‘dbConn’. Apparently the dbConn.aspx was not updated.
Is Wappler using the aspx file or the json file? Is this a bug? Is the causing the records.aspx page to throw the null error? (see screen shot below)

It seems to me there is a lot of mixup here with makings and files. Also you need to define an Application in IIS to define your app there.

It might be better to not place it in a sub folder or if you do you have to make sure the root url points to it.

Anyway as suggested in the other topics IIS setup can be pretty complex and does require good interstanding of IIS and the way it functions and is setup.

So if you choose it just for learning I would suggest to select NodeJS instead.

The application is set up in IIS Server as I’ve set up other asp.net apps. The web.config file is certainly a suspect here but I’ve tried many different changes to it with no success beyond getting the authentication/permissions set to allow an aspx page in Wappler to run, and that was somewhat involved but a huge success. The only question left is what does it take to make a Wappler app run on IIS?

I’ve never used nodejs and only purchased Wappler because it claimed to work with my existing technology–I shouldn’t have to abandon Microsoft products such as Visual Studio, .NET and IIS Server. I feel Wappler should have already thoroughly tested their product on Microsoft IIS Server and offer some kind of guidelines as to use Wappler with IIS Server.

I do appreciate all the help you have provided, but if the company’s position is I should change my technology stack to something else they should at least put a warning or caveat on their website cautioning against using Wappler with Microsoft IIS Server. It would have saved me a lot of time and money.

Thank you

Well you can use Google to lookup information about how to setup IIS and upload folder permissions.



Yes, I’ve been using IIS for years without any issues. I am familiar with setting up an application’s virtual directory, the relevant application pools (including configuring their relevant folder permissions in Windows; also setting up SQL Server logins/users when the default appPool and Windows authentication is not supported, as in Wappler), web.config files (and their inheritance) and integrating all of it with MS SQL Server. The only thing I’m having issues with is Wappler, and the documentation does not help me in this case.
btw the link references an out of date version of IIS Manager and is no longer relevant.

The Server Error seems to be related to the HttpSessionState. Do you use default session handler or do you have some configuration changed for sessions?