Some dynamic content no longer working in v6.5.0

Wappler Version : 6.5.0
Operating System : Mac OS 14.4.1
Server Model: NodeJS
Database Type: MySQL
Hosting Type: Docker

Expected behavior

What do you think should happen?

Dynamic bindings in content generated from the database in a repeat to work as they did before updating to 6.5.0.

Actual behavior

What actually happens?

I’m working on a custom CMS and I store some content in the database that contains dmx bindings and it’s been working great until I updated to 6.5.0. Some content that is generated in a repeat with data from the database that contains bindings suddenly doesn’t work as it did before.

How to reproduce

All I did was update to the 6.5.0 and now pages that worked fine, are not having their bindings replaced with the data, alerts are showing when they shouldn’t and don’t have the proper styling, the button spinners appear when they shouldn’t. Images are missing. Here is a couple examples.

Image, alert and form all render normally.

Bindings with proper values:

Image is missing, alert shows by default without styling, checkbox in form not checked by default as it should be and button spinner appears when form is not submitting.

Bindings not getting the values:

This project is dead in the water if I can’t get this to work again in the new version.

Thanks in advance guys,

Have you tried opening that specific page up in Wappler then saving it again? I had something similar with charts, when I went to open the page, before it loaded Wappler identified some changes that had occurred and asked me to update. Once that was done it worked as it should.

Thanks for the reply @TMR, I’ve resaved the partial that contains the content repeat, but let me try and some some of the layout pages etc.

I also, don’t know if Wappler prompted me to update extensions or not and not sure how to force that update. Just a thought for troubleshooting.

Do you have any errors in devtools in the browser? Seems like dynamic data from App Connect is not rendered at all, so there must be some fatal error

Thanks for the reply, @George. The console does have a few errors but these don’t look like anything that would cause the issue.

In the network tab, the correct data from the database query does appear correctly.

Also, I did what @TMR said and resaved my main layout file and it did give me the alert that some components had changed and I saved, but didn’t fix it. I have also redeployed with no luck.

I tried using the AppConnect 1 channel and that didn’t work either.

I tried rendering some of the content from the database outside of the repeat, and it still doesn’t work.
If I copy and paste the html from the database field directly onto the page, everything renders normally.

I’m wondering is the issue is with how the data from the database is rendered using dmx-html=“text_html”? Like I said, it worked flawlessly until I updated.

Are you sure you uploaded all the latest js files from the dmxAppConnect folder to your server, after they’ve been updated locally?

Well seems you have quite a few errors that needs to be solved first.

The event calendar was also updated a while ago with new includes, so make sure all files are uploaded as it seems you might be missing some.

Also you seem to have some illegal expressions as well.

I’m working locally so there shouldn’t be anything to upload if everything updated when I updated Wappler, correct?
Is there a way to force everything to update? Would downloading Wappler and installing over it help?


Yes, set the channel to stable, click change channel, then enable Force Update - App Connect Components:

Screenshot 2024-04-18 at 16.40.03

And when previewing the page in your browser don’t forget to clear the cache.

I don’t seem to have that option, unless I’m looking in the wrong place.

You need to open the project assets updater …

Ah yea, forgot about that extension updater. Unfortunately that didn’t fix it. I also fixed all the console errors (except the .map ones) and that didn’t help either. :pensive:

Ok, it definitely appears to be an AppConnect 2 issue. Earlier when I switched from Stable to AppConnect 1 channel, I did it from the “Options” menu and that didn’t work. I just swtiched it from the Extensions Update Channel and now everything works as it should.

So when on App Connect 2 stable and you have this issue, there are no errors in the console at all?

When on App Connect 2 Stable, these are the only errors left (after I fixed the other ones I sent earlier) and it does not work as expected.

When on App Connect 1 these are the errors that appear, but everything works as expected.

If I take the code that is stored in the database and place it directly on the page, it renders fine in App Connect 2, but it doesn’t render correctly in App Connect 2 if pulled from the database in a query and rendered via dmx-html="" or using {{value}}

Thanks again for working on this with me.

Can you please explain more detailed what exactly are you doing? Code stored in the database? Please provide more details.

I’m basically storing html along with bindings in a column in a database table called ‘content’ in a column called ‘text_html’. Each page can have multiple content connected to it. So when the page loads, I get the content that is for that page in a server connect query, then I have a repeat that renders out the content.

Here is the code for the repeat.

<div dmx-repeat:repeatpagecontent="">

  <div dmx-html="text_html" dmx-bind:class="container_class" dmx-style:background-color.important="container_bg_color" dmx-style:color.important="container_text_color" dmx-style:background-image.important="bg_image?'url(/assets/img/''/content/'+bg_image+')':'none'" dmx-style:min-height.important="min_height" dmx-style:min-height.important="min_width"></div>


Here is an example of the copyright content stored in the database that is rendered using the query and the repeat above.

<span class="navbar-text p-2 d-none d-sm-block d-md-block small text-center">© Copyright {{varCurrentYear.value}} | <a style="text-decoration:none;" target="_self" dmx-bind:href="">{{varAppName.value}}</a></span>

This all gets rendered inside of dmx-view which is in my main.ejs layout.

<div is="dmx-view" id="content" dmx-style:--theme-primary.important="varPrimaryColor.value" dmx-style:--theme-menu-bg-color="varMainMenuBGColor.value" dmx-style:--theme-menu-text-color="varMainMenuTextColor.value">
    <%- await include(content, locals); %>

All that above works in App Connect 1, but does not in App Connect 2

Hope this helps.

Thanks as always,