Server Connects outputting everything as text

Wappler Version : 5.3.2
Operating System : Windows 11
Server Model: PHP 8.1
Database Type: MySQL
Hosting Type: Reseller

Expected behavior

Numbers should be output from server connects as numbers, not strins

Actual behavior

All numbers are output as strings.

Here is a sample database setup…

I have a query like this…

The output code looks like…


I’m trying to use the chosen field in an external library as boolean but because it’s returning text it’s not working.

If I output data from an API call it outputs correctly…

I noticed this the other day but am not sure if it’s always been that way. As I mentioned to @Teodor I remember having to use .toNumber() in the past but as I wasn’t doing a lot of work with numbers it wasn’t a big deal. Now, however, I really do need the output to be correct.

What mysql version are you using?
And what is this setting in your database connection set to:

MySQL Version 10.3.36-MariaDB-cll-lve

I tried Auto and False there but that didn’t fix the issue.

How to return integers and floats from MySQL with PHP PDO (

You have to set Prepare Statements to False. The other option for converting numbers to strings is already disabled inside our code.

I tried that. It’s still outputting as text. Also, I have some custom queries that won’t run if that’s set to false.

Also, I tried casting the value to a number in the query and it still output text.