Sendmail, not Wappler related


#1

I just want to ask, and it is totally unrelated to Wappler.

I have a VPS server with InMotion Hosting running WHM with root access on CENTOS 7.6 and my website hosted on the server has an enquiry form on it. When completed the form should write the content of the completed form to my MySQL database and email about 5 people the entire contents of the form.

It worked flawlessly for 2 years, never missing a beat, database and user emails. Then about a month ago I was noticing database entries that were added but no email that was being sent. I eventually went to tweak the settings and turned off SpamAssasain for email on the server, did some testing and all was working as expected again.

On the 31st December 2018, suddenly I notice that 3 enquiries were entered into the database, but no email for them again. I honestly do not understand why and do not know what to try to make it work 100% of the time. Is this just a sendmail issue, and should i not use sendmail and rather use proper SMTP? Just not sure how it all works wonderfully for so long and then just doesn’t considering i have made no alteration to it.


#2

try avoiding sendmail. But check if your Server is blacklisted https://www.mxtoolbox.com and go with SMTP with Auth.


#3

Anything in the sendmail logs?

They will probably be in something like
/var/log/mail.log
or
/var/admin/mail.log


#4

Thanks Hyperbytes, I found them, and it is still somehow spam assasain, I have turned it off in another 2 places and now it works again, i never imagined i would have to turn it off in 3 different places for it to actually turn off properly.

Oh well WHM can be quite a tricky beast sometimes. Thanks again.

And thanks @Freddy_Blockchain, I normally use SMTP with Auth, but in this particular case I had a small issue with it because of running the entire site through MaxCDN/StackPath CDN, and for some reason it tends to block it.