Routing will not display in Browser


#1

Version: 1.9.4
O/S: Safari Sierra

Toggle Preview Mode in Wappler displays SPA properly.
Open Browser Mode in Wappler displays only a blank screen.

I stepped through the development. Everything displays in the browser and in preview prior to creating the first routing for a section. I followed your tutorial to see if I missed something. I confirmed the steps described in the tutorial.


#2

it works for us on 1.9.4.

have you uploaded the routes?
image

you’ll have to share more information, few screenshots of your setup and settings for us to be able to help you.


#3

Thank you for your reply. The routes were generated and then uploaded. No success. I will upload the screenshots to further assist you.


#4

Can you please send a link to your page where we can check this?
Also - what is the content of your htaccess file?


#5

Hi Theodor.

I tried to upload the htaccess file as requested but failed. Apparently, it does not accept UNIX files (I am on a Mac). In light of that, I have uploaded a screenshot of the htaccess file for your review.

The link is doctorsmis.com.
13%20AM


#6

What’s your server? :slight_smile:


#7

Live Server: Windows 2008 R2

Desktop: MAMP Pro Version 5.2.2


#8

Well Bruce,
You need to select IIS handler in your project settings. It will create a web.config file for your Windows server.
.htaccess files are for Linux server.


#9

I switched it from Apache to IIS. Issue persists.


#10

Did you regenerate the routes and did you upload the web.config then?


#11

Per your instructions, I have regenerated the routing and copied the entire content of the site to the Windows server. No success. Tried testing in Wappler browse and no success either. Web.config uploaded successfully.


#12

So what’s not working exactly? I see the _Home.html page content when I load the site.
How to reproduce the issues you are having?


#13

I emulated your tutorial for SPA with the exception of naming the “portfolio” to “transcription”. It appears to be working under “Toggle Preview Mode”. The home page does not appear to display on startup. When in “Toggle Preview Mode” I am able to successfully display when switching from the “Transcription” menu to the “Home” menu option back and forth. But, When I select “Open in Browser” the browser opens but no content is displayed. No menu, nothing. The same occurs when I publish to the doctorsmis.com site.


#14

Your site is displaying perfectly fine, even on my phone:


#15

Maybe clear your browser cache? I see the routing working on your site.


#16

Here is a copy of the Project Settings.


#17

I returned. I see that it works in IE but not in Safari. I cleared the cache. I quit Safari and opened it via “Open in Browser”. No luck. I guess it may be incompatible with Safari.


#18

Works fine in Safari for me as well as Chrome and Firefox. Works on mobile as well.

Perhaps you just need to clear your browser cache.


#19

Hi Brad. Totally concur with your findings. It just doesn’t work with Safari. I will test on another Mac to confirm.


#20

It does work on my MacBook Air Safari. Now I am baffled as to why it does not display on my desktop/development computer.