Repeat on Exec action returns Empty List in Exclude/Include field options

Wappler Version :4.9.1 and Beta 5.6
Operating System : Windows 11
Server Model: Node JS
Database Type: MariaDB
Hosting Type: Docker

Repeating the output of an exec action should return a list of fields as it does with other actions.

What actually happens?

The repeat returns an empty list, output is enables for the exec action.

image

I’ve tried in 4.9.1 and 5 beta 6, both show the same.

Hi.
The query that you have in library SA, is that a custom query?
If so, you need to run it or set the schema manually for the columns to show up in output fields.
If its a regular Wappler query, add a set value step and check from the value data picker if the schema is showing or not.
If the schema is present, repeat should show them in output fields.

If it still does not, its probably a bug with exec queries & repeats then.

Thanks Sid.

Just checked with set value and the fields all show OK here. It’s a standard query (not custom), the same query works fine as a repeat if I run it inline in the API. Seems to be an issue with exec and repeats I think?

Very likely.
@patrick could you please check.

Just bumping this…looking to use library actions as to feed data exports and can’t currently select which columns to include/exclude.