Remote host throwing an error for SQLite

What am I missing? The site works like a treat on the local host, but throws an error on the remote for

The error message:
{"status":"500","message":"Knex: run\n$ npm install sqlite3 --save\n/lib64/ version CXXABI_1.3.8’ not found (required by /var/www/vhosts/",“stack”:"Error: Knex: run\n$ npm install sqlite3 --save\n/lib64/ version CXXABI_1.3.8' not found (required by /var/www/vhosts/\n at Client_SQLite3.initializeDriver (/var/www/vhosts/\n at new Client (/var/www/vhosts/\n at new Client_SQLite3 (/var/www/vhosts/\n at knex (/var/www/vhosts/\n at App.setDbConnection (/var/www/vhosts/\n at App.getDbConnection (/var/www/vhosts/\n at (/var/www/vhosts/\n at App._exec (/var/www/vhosts/\n at App.exec (/var/www/vhosts/\n at App.define (/var/www/vhosts/"}

Edit: This looks to be a bug, hence changed the the category accordingly.

This exceeds my knowledge, but I can say that SQLite 3 is looking for a dependency on your system that doesn’t exist, so you can start spitting out your Linux distro, version and all that stuff


1 Like

Thanks for the prompt reply. According to the link, it looks like the wrong version of Ubuntu is being used.

Will wait for a few more replies before contacting the host.

Yes seems like a missing dependency, maybe update the system packages to the latest if not done automatically.

Thank you George. But no change.

Re-categorised as a bug.

Can you try on the terminal of the remote host:

npm install sqlite3 --build-from-source

Thank you for your reply. The problem is:


Can you ask them permission for SSH access?

I know years ago things used to be different and hosts were reluctant in giving SSH access, but I hope things are different nowadays

I did ask them a few months back, but they refused. At the time I found a workaround so it was not a problem and it was an ask, not a demand. May change my tune tomorrow when the crew is back on board.

What is your exact server OS and version?

Also what node SQLite3 version are you running?

You can check package.json or do npm list sqlite3 On the server in the project folder.

I’ll get in touch with the host tomorrow after which I’ll get back to you.

You might want to try to change the sqlite3 version in the package.json to the latest 5.0.8

It was very recently updated and it solved quite a lot of problems.

Tried that without luck.

Got in touch with the host, waiting for reply.

This is the reply from my host:

"I can confirm that SQLite is already installed and available on the server from your user account:

[benp@plesk-sln2 ~]$ sqlite3
SQLite version 3.7.17 2013-05-20 00:56:22

The error that you are getting appears to be related to some other dependency that I am not familiar with, CXXABI. Can the Wappler founder provide any insight into what this is and how to fix? We can provide him / you with SSH access to troubleshoot further if required, but that will require a firewall change to allow access from a whitelisted static IP address."

Well that won’t help - we don’t use any sqlite global commands available on terminal.

We use the binary supplied with the node-sqlite3 package.

Please verify that you are using the latest 5.0.8 when you run npm list sqlite3 on your remove server in the project folder.

Also supply the exact OS version, simple environment variable fix like the one specified above by @apple might be all you need:

You host can help you with that maybe, for the exact location.

Btw maybe your host have older gcc version less than 4.9 installed (that must be really old!)

So let them install at least gcc 4.9

See also:

Another idea:

When you installed your node modules on the server - was there already package-lock.json available?

Maybe try clean install on your node modules on your server by deleting the package-lock.json and node_modules first and then run npm install