reCAPTCHA Validation Question


I have setup a contact form in PHP via Server Actions that I am able to successfully send. I then added a reCAPTCHA Action Step that does not validate properly. The form is able to be submitted without having checked the “I am not a robot” checkbox.

What I did try was to move the Action Step above & below the other Steps in the stack & I have moved the actual reCAPTCHA div on the page inside & outside of the actual form. It will not validate.

Any ideas on that,


I think this line is missing in the HTML, Wappler was supposed to insert it:

<script src="dmxAppConnect/dmxValidator/dmxValidator.js" defer=""></script>

That would prevent the form from being submitted without completing the captcha

Regarding your Server Action, the reCaptcha validate step should be the 1st step

Hi Jim,

As mentioned by "Apple"you need to add the reCaptcha BEFORE the mail sender step.
You may also find some important info on that post about configuring the reCaptcha: [Can captcha be used with wappler?](http://About reCaptcha)

Good luck :slight_smile:

Thank you kindly, that seems to have worked, my form is validating. :+1:

1 Like

So now my question is how to make reCAPTCHA more robust. Seems I have actual humans spoofing my forms, just needing to check the reCAPTCHA box is simple enough. I have increased the complexity level of the CAPTCHA on the google admin side, which seems to have no effect, it is still a simple checkbox. Are there any options available to configure to increase the difficulty. Also how would I customize the alert message when skipping the CAPTCHA field?


There are services where you pay real humans to solve captchas. When I’m home I’ll double-check your form to see if it’s really working


Clicking your link I get a CAPTCHA with a puzzle maybe you just need to clear your browser cache?

Can you try to remove the captcha element through the browser’s dev tools and see if the form submits successfully? Just want to check if it’s working the server validation

I agree with Sorry … likely a browser cache issue. Seems to work fine for me.

Huh…Interesting, I am not seeing that in several browsers. Thank You.

On a Windows pc have you tried CTRL and F5 in chrome?

Or for Mac Shift and clicking the refresh circle in safari

This will refresh the cache and should load the page fresh rather than the cache version I don’t know the refreshes for other browsers but you could search the shortcuts for them etc.

Thank You. Hmmm, not sure, even after restarting my computer & trying the form in a browser that had never gone to that page & CNTRL-F5 every other browser, which are all the latest version, & removing the reCAPTCHA with Browser Dev Tools I still only see a checkbox. Seems the CAPTCHA still validates even without it on the page.

Thank You. After fiddling with it & the admin control panel It appears to work.