Problem creating new Server Action files


#1

When creating a new action file, a file with the default name New File is created. Most of the time, the name has the standard border round it and is highlighted - so it can be edited. However, quite often, the file name cannot be edited and appears without the borders etc:

image

This has been a problem for some time - but only from time to time.

Usually, deleting the file and trying again works. I think creating a new file in the other way - right-clicking on an existing file or folder - is more reliable, but this doesn’t always work. Just now I tried several times, using both methods, without any success. I’ve just tried again now, and it worked.

Not a big issue, but it would be good if it were fixed.


#2

Yes, i get that occasionally. as you say not a big issue but is a minor irritation


#3

I full action file rename, move with drag & drop - will be available in the update for today :slight_smile:


#4

Great - happy/wappy Thursday again.


#5

Will these be these options be included too:

image
?

I would find these really useful.


#6

in the context menu yes:

image


#7

I meant the ‘Upload’ and ‘Show in Explorer’ options specifically. They’re not in your screenshot.


#8

ah those … well Server Actions are actually always auto uploaded on save.
Why would you need to upload it manually?

Also there is open in editor option in the toolbar. Why do you need it in explorer?


#9

I may be working on a set of server action files locally. Then I want to upload them. I switch to the remote target - and then I don’t actually know what the intended procedure is.

I don’t need to save the files again (they’re already saved), but I need to - to upload them. However the option is usually disabled anyway:

image

So I have to click on some steps to enable the save button - and then save the current file. Quite a nuisance if it’s a folder of new files. I usually end up using FileZilla. A right-click upload button (or at the top of the panel) would be a much better option. Even better - a folder upload option as well.

For copying files and reorganising them etc… I know you’re adding new file management features, which most of the time will be sufficient, but they’re not going to match the options in Explorer. I’ll often copy a file to modify for a similar purpose, rather than start from scratch, or I may just want to make a copy before trying something out which might mess up what I’ve done. Etc…

I use the right-click Explorer option in Wappler’s file manager all the time - it’s really useful, and frustrating it’s not in Server Connect too.


#10

Thanks for adding these extra options - I shall find them really useful.