Preventing the Design View from running restricted access

I have a page that restricts access based on the login info, but when i open that page in Wappler, it automatically sends me to the login screen and i am unable to preview it.

is there a quick way to stop that from occuring so i can work on the page in Wappler?

You can:

  1. Log in with your credentials

Or

  1. Disable App Connect (thunder icon on the top toolbar)
1 Like

i did unclick the Thunder icon and hit Refresh Design View, but it still occurs.
Its an INclude script that the redirect is linked to…does that make a different?

What kind of redirect exactly are you using?

It shouldn’t make a difference. If the App Connect is turned off it shouldn’t redirect. Do you by some chance have it in Preview Mode?

Screen Shot 2020-09-14 at 9.22.01 AM

I have everything unchecked and it is still redirecting based on a failed login/ See the highlighted INclude script

the redirect occurs if a session variable is not set.

Also, if i have an include file that i want to work on, i click on the arrow to work on that page, however when it opens up, its only in code view and doesn’t allow any Visual option to see the changes i am making. Any way to do that? Similar to how Dreamweaver allowed you to open up the file separately and work on it.

How did you create the include file? Sounds like it doesn’t have all the comment code in it that Wappler requires.

it is a site transferred over from Dreamweaver

That would be why it’s not showing in Wappler.