PDF Creator Questions

<link rel="shortcut icon" href="#">
After added above , the error disappear. But PDF still no response.

Not at all!
So when you click the generate pdf button you don’t see anything strange on console?
I’ll give a try tomorrow

Thanks

I think I already know where the problem can come from. But I’m not with Wappler until tomorrow.
It’s probably the lack of writing permissions.
Can you enable file writing permission with a flow before generating the pdf (download)?
I don’t know if you need an additional code, I can try it tomorrow.

Please see the write file point:

I not sure what to put in path and data and just copy sample by google. But it does not work.

Hello Teodor,

As you said I had been able to use PDFCreator under Beta channel.

But today I reinstalled my old archieve version of my project and started all over.

All again updated Beta channel extensions by using update options of Wappler.

But this time there was no dmxPDFCreator.js can be installed by using Wappler “Project Assets Updater”.

There is no dmxPDFCreator can be seen under “Assets to be updated”.

I am using Force update option to see all of the extensions.

But it is not in the list anymore. 3 days ago, I could be able to download it and used all ok.

Console Error:
dmxPdfCreator.js:1
Failed to load resource: the server responded with a status of 404 (Not Found)

Can you see this?

image

Than you will be able to add as below

My problem is not the usage inside the wappler.

Yes I can see it as PDF Creator 1.0.0.0 - beta.1 unser extension manager.

My problem is no file under “dmxappconnect/dmxPdfCreator” thats why the PDF creator can not generate pdf files.

I am using node.js , so I don face the issue that you are facing.

can you provide an example for this “define pdf styles under the pdf creator”

You add the PDF Style as a component under the PDF Creator

image

In the Properties you define a Class Name and configure the style for it.

Then on the element where you want to apply the style you add the class name.

image

The style will not be visible on the page and will only apply to the generated PDF.

3 Likes

Perfect Perfect Perfect. Thanks much

I have been trying to use pdfcreator on a site where a pdf is created based on realestate content in a database. I can generate a reasonably good pdf document and download it.

I think what is missing is dynamic responses from the generator. Success, error at a minimum. At the moment I have a button that on click loads pdf creator download which generates a document based on a column which has id pdfcontent1. This all works well until it doesn't eg. if you use a repeater for a table body and the repeater is empty the pdf creator will stop due to tag errors - not finding the expected tr for the table (overcom by creating a static tbody that is hidden if the repeater has data).

When pdf creator finishes there is nothing you can use to display a message or unhide a form to upload the downloaded document to the database. I suspect this is because it is a client side function whereas I am used to working with server connect. Any advice on how to trigger actions based on pdf creator success or errors would be greatly appeciated.

Good morning!
I'm trying to generate a PDF with PDF Creator, but when I insert an image in the header, the PDF is not generated. What could be happening?
Below is a print showing how I am inserting the image.

Thank you in advance for your help.

Well, when updating to version 6.7.0 it worked. But, when inserting the image and text next to each other, they are not level. The logo is above the table where I list the content of the pdf and the text at the top. If I give a margin-top of 0, it raises the image but also raises the text that disappears from the PDF. I don't know what to do to adjust this. Ideas?