Overlapping ranges are not allowed!

OS info

  • Operating System : Windows 10.0.17134
  • Wappler Version : 3.4.1

Problem description

Got the error “Overlapping ranges are not allowed!” after some changes. On my partial view (.html file), I first added a BS4 table, then a dynamic modal, then switching frameworks from cdn, then back to local (was testing something). After that I couldn’t save. It was solved by copying the code to notepad, closing the file without changes, opening the file, and pasting the exact code back in, so it’s not the code!

Steps to reproduce

I think I found the steps that causes this:

  1. Create a project with a static index.html file. Make all frameworks local.
  2. Create a partial view with a BS4 table and modal window, then embed it into index.html.
  3. Change the bootstrap framework in the partial view to CDN.
  4. Can’t save the partial anymore. Can’t even switch back to save it.

Your framework includes must be on the main page, not in the partial. Not sure how did you manage to change the framework in the partial but it’s not the right place to do this.

The partial puts framework details in the comment at the top of the partial view. I didn’t put it anywhere. :wink:

If you can recreate this, please copy the exact code of the partial comment on top and make a screenshot of the error.

Ok, I can recreate this. All I did was go to my partial view and add a BS4 Modal window. I then tried try to change Bootstrap to CDN, that’s it.

Attempting to save the page results in this:


No way to undo the error, except to copy code, lose changes, reload the partial, and past the code back.

1 Like

Thanks for the info, we are going to check this.

1 Like

We have improved that in the last Wappler updates

Could you check if it is still an issue?